[SOLVED] Animation Artifacts in Ogre

Hello community,

I have done a model and a walk cycle in Blender and exported it to the Ogre .mesh and .skeleton file format respectively. As I started Ogre I got the errors you can see on the screenshot:


The whole animation problem can be reduced to two bones: the upper and lower leg bones. If I just rotate the upper leg without touching the lower leg everything animates correctly but as soon as I manipulate the lower leg too, I get these errors. To understand what might went wrong I have redone the skeleton with just those two bones and to my suprise: even with the lower leg rotating everything was correctly animated in that new skeleton. So I compared both skeletons (the old and the new) but I wasn’t able to see a difference between them.

So here is a link to a zip file with both versions of my skeleton animations as .blend files. The working one and the not working one. I kept the animations simple to make it (hopefully) easier to find a solution:


Recapture: In Blender both animations work fine. It’s Ogre where the problems occur with one of the animations. So there has to be a difference in those two mentioned files.

Can anyone of you guys please check my armatures in that files? Is there an option set for one of them which isn’t set in the other?

I solved it on my own now. Unfortunately it’s a stupid mistake of mine. I scaled the armature of the not working animation.However I didn’t do that on purpose so I was looking in wrong directions. Nevertheless, it works now (I removed the scaling).