[SOLVED] bitmap font in BGE - words are reversed (see screenshots)

Hi all,

I’ve been following several tutorials which I’ll link to at the bottom of this post, they concern getting bitmapped font set up within BGE.

Anyway I’ve followed all the steps and things are ok, except there are 2 major issues:

  1. Words are reversed, so if the ‘Text’ property is set to ‘Hello’… I instead see ‘olleH’… this happens with numbers too. I’m using US english under linux.
    The words are also reversed when they appear in the 3D viewport, ie before BGE even starts. I thought of rotating the plane around but then the text isn’t visible from the underside of the plane.

  2. The letters aren’t on the same horizontal line… look at the screenshot… this small issue would be a killer for my use. Could it just be the sample .tga fonts image/texture they provided has some problems ? But then again the screenshots in that tutorial don’t show this issue.

To clarify very quickly those 2 issues, I’ve included 3 hi-res screenshots that show the settings and output from Blender. It’s worth nothing that I’ve tried several versions of blender but no difference. Any help would be greatly appreciated.

Tutorials I followed:
(this had the sample .tga arial font) http://www.blending-online.co.uk/8501/17001.html


you’re looking from the wrong side, maybe…
try to turn or mirror the plane or turn/mirror the UV ( Shift-F keys)?!

Haha that’s the most hilarious problem I’ve face with blender, rotating the UV map itself 180 degrees fixed both issues.

Thanks OTO :slight_smile: