Solved! Can I get rid of the grey haze in wireframe in edit mode?

Is there a way to make the wireframe clear? In Object mode, in wireframe, it is totally clear but when switching to edit mode there appears to be a greyish haze in the object even when in Toggle X-ray.

It makes seeing my edges harder unless an edge is selected.

Thanks for any help

I went into the “Shading” tab. Under the Options section in X-ray I simply put the value down to 0. That worked.