[SOLVED] - Cannot select Fire + Smoke in flow type...

Hi there, I trying to have a little experiment with smoke and fire in cycles, not sure what I’m doing wrong but I can’t select Fire+Smoke in the flow type of the smoke sim.

Whatever I select, when I click back on the domain it goes back to being just smoke.

this happens on both the official 2.71 release on my mac, and also had a quick try on 2.67 on my work PC and I have the same issue…

What am I doing wrong?


I was trying to set the flow type with the domain selected, rather than the smoke/fire emitter sphere.

As a suggestion I’d say some sort of dialog box to alert the user that the flow type needs to be set on the emitter would be helpful

The documentation should be sufficient to alert users of this fact: http://wiki.blender.org/index.php/Doc:2.6/Manual/Physics/Smoke/Flow_object

A warning dialog is no substitute for reading the manual. We would quickly end up facing an annoying popup every time we tried to do anything.

Hmm… Ordinarily I’d agree, but considering I was following a tutorial and ended up stumped I’d argue that in this case I’d have rather had that warning/popup. After all, I’m not likely to try to do that again.

In fact, scrap that - why does it even seem like I am able to select anything other than smoke in the flow pane when I have the domain selected, if it will always default back to smoke?

When you say “flow pane” do you mean you have the domain object selected and you’re clicking on this button?

Those aren’t panes. Whichever of those buttons you have selected is the smoke sim object type of the selected object. If you click on Flow there, you’re not switching planes. You’re changing your object to a Flow type instead of a Domain type. The buttons below that row change contextually based on the object’s type, so it then shows Flow options instead of Domain options. You’re creating a smoke sim with two Flow Objects and no Domain. It then doesn’t hold any of your new settings because you’ve created a broken simulation without a Domain to hold it.

Again, reading the manual would serve you better than a popup dialog. You want a warning when you try to put a flow type on a Domain object, but that’s impossible. Domains don’t have flow types. You cannot possibly change the flow type of a Domain object. You have to actually change the object to a Flow object first, which is what you’re doing.