(Solved) Parenting Mesh to Armature Adds Vertex Groups But No Weights

Not sure what the problem is here. Also, no vertices get added to the vertex groups. I’ve tried creating a new rig and parenting the mesh to that but end up with the same result, which leads me to believe that there’s an issue with the mesh.

Blend file is attached, hopefully someone can take a look and offer some insight.


GameCharacter3.blend (692 KB)

I’ve run into this problem a few times. I don’t know if it’s a minor bug or what, but sometimes parenting with automatic weights fails for no apparent reason. Fortunately the fix is easy:

First, the usual stuff. Make sure your mesh object doesn’t already have an armature modifier, make sure its scales and rotations are applied (ctrl-A in object mode. Do the same on the armature). You’ve already done this stuff in your file; I merely include it for the benefit of others. Put your armature in pose mode.

Now here’s the fix: put the mesh object in Edit Mode, select all, Ctrl-N to recalculate normals. Your normals are all fine already, but trust me.

Then pop back into Object mode, select the mesh, select a bone in the armature, hit Ctrl-P>Automatic Weights, and it works.

Why does correcting already correct normals solve this problem? Dunno.

Whacky. Just tried it and it seems to work. Thanks!

K Horseman, has this bug been reported yet? If not, ifcruickshank, do you mind if I submit your .blend file if it has not?

I have not because until today I couldn’t find anyone who could confirm the problem for me. I wasn’t sure until now that it was a bug and not just my machine hiccuping. It happens inconsistently, so I don’t know what causes it, which makes it hard to replicate.

The good news is ifcruickshank has a file that consistently exhibits this behavior. Since you found it, K, do you want to report it?

Sure, I’ll take care of it. Thanks.

Thanks K Horseman!