[SOLVED] Run Blender without the "./" in Ubuntu


When I install Blender from the Ubuntu repositories with

sudo apt-get install blender

I can run Blender with just


However, I asked around the IRC channels and they recommend against using Blender from the repositories. Besides, I couldn’t get the latest Blender from there. I should download from the official site instead. I have several questions about what to do with the resulting .tar.bz2 file

  • Which directory should I untar the file?
  • How can I run Blender from anywhere in the command line? I tried setting the PATH variable in .bashrc and also using the export command, but I can’t still can’t run Blender from anywhere.
  • This question is closely related to #2. Somehow, despite setting the PATH variable, I still can’t run Blender from anywhere since it requires

as opposed to the apt-get install where I can just do


Thanks in advance! :slight_smile:


I don’t think it makes a difference, so this is up to you.

Are you sure you’ve set your PATH correctly? What do you get when you type the following?

echo $PATH

if you really want to run “run Blender from anywhere” ( I don’t see the need?), you can do a quite ugly hack:
sudo ln -s /path_to_new_Blender_directory/blender /usr/bin/blender2
this command makes a symbolic link in /usr/bin directory to the new Blender executable
The “blender2” name is to avoid conflict to the existing one
Then you can type in a terminal blender2 and it should work…I hope!

Make a terminal alias.

Open .bashrc and add something like this(you can check somewhere like ubuntuforums.org to make sure I got this right):-

blender = ‘path/to/blender/executable/./blender’
Then whenever you enter blender in the terminal it will run the command for you.
You might want to call it something other than blender in case you ever want to install Blender in the future but it is of course up to you.

Another option would be to make a Desktop or panel launcher and set its properties as ‘Application in Terminal’, browse to the Blender executable you want to launch and job done.

I think I should have rephrased the question to “Which (default, or best practices) directory should I untar the file?” It does make a difference, in terms of consistency and standards :slight_smile:

I’m working on a render farm (hence my interest in learning Linux). The queue manager I might be using might need to somehow call Blender “from anywhere”.

I also asked this question over at the Ubuntu Forums (here’s the thread), and based on the community’s suggestions, I’ve formulated a solution:

Okay, for everybody’s benefit, absolute beginner style, here’s what I did:

  • Create a directory in my home folder for any archives that I download manually
mkdir tars
  • cd into the newly created tars directory
cd tars
  • Download the .tar.bz2 Blender archive from the official site with wget
wget http://download.blender.org/release/Blender2.49b/blender-2.49b-linux-glibc236-py26-i386.tar.bz2
  • The following instructions will require root privileges, thus the sudo at the beginning of each command.
  • Copy the .tar.bz2 to the /usr/local directory
sudo cp blender-2.49b-linux-glibc236-py26-i386.tar.bz2 /usr/local
  • cd into /usr/local
cd /usr/local
  • Untar the Blender .tar.bz2
sudo tar xvjf blender-2.49b-linux-glibc236-py26-i386.tar.bz2
  • Delete the .tar.bz2 for clean-up purposes. Anyway, you have a copy of this archive in your ~/tars directory.
sudo rm blender-2.49b-linux-glibc236-py26-i386.tar.bz2
  • cd into /usr/local/bin
cd /usr/local/bin
  • Create a symbolic link to your new Blender executable
sudo ln -s ../blender-2.49b-linux-glibc236-py26-i386/blender blender
  • Now, just to prove that you can run Blender from anywhere, cd into any other directory and type

Problem solved! Thanks everyone!