[Solved] Weird shadows, normals messed up

Hi, this is a problem i came often across. union is great, but when it comes to advanced, and complex meshes it usually messes up. so you have to reedit by hand. but when you do so, you come (often) across a weird shadows problems. at least in my advanced starter user case. the whole mesh made with union looks perfect, while the face you edited are like a fly into the soup you know.
here, how do you fix that. the meshs i’m making aren’t really complex, so if somebody has tips to make unioned forms easily i’ll take it. as you can see the upper untouched part of the mesh is perfect, while the lower i touched is weird

Make sure normals are ok, points defining an edge is actually hooked up as an edge, and faces don’t consist of odd geometry or very stretched geometry. Non-manifold edges that connects more than two faces or loose edges can also be a source for problems. I use the knife tool a lot on imported sheet metal parts, then spend a while cleaning up the geometry, aiming for good enough rather than perfection. In wireframe mode, try moving verts around and see if any double edges gets revealed.

1 Like

This could be due to smooth shading and the ngons. If you go to object mode and right click – “shade smooth” it is possible that the top part will also turn ugly. Sometimes smooth shade does not update automatically after editing.

One thing you can try is add a bevel modifier with 2 segments and the shape set to 1 (which is flat). That should work if this is the case as it will add support loops around the square holes.

If this does not work (or you get these results with flat shade), as Carl says you will have to check for double faces etc and correct geometry.

2 Likes

i finally found out what the problem was. it was auto smooth. by unchecking this i got the good stuff back. i made a quick search, but couldn’t find what that thing does exactly. looks like a kind of modifier for fast, simple formed modelling?
i didn’t loose my time as i discovered how to tag inside/outside faces with the face orientation
Capture d’écran 2021-02-26 145622

Thanks for the help guys.

Auto-smooth sets the mesh to smooth-shade any edges with an angle less than that specified, and to sharp shade any edges with an angle greater than that specified. It’s also necessary to use custom per-face normals, if you have any specified, or to use marked sharp edges.

If the model looks good when you disable autosmooth, then it probably controls its normals via control loops, and it probably has some inappropriate custom normals.