some problems

I have 3 major problems in the blender game engine, and here they are:

  1. I’ve tried it on 2 computers now, and armatures do absolutely NOTHING in the GE (probably my biggest problem)

  2. I can’t seem to get alpha to work in textures

  3. track constraints don’t work (I’m not sure if they’re supposed to or not, though)

I did some searching before asking, but I must be really bad at finding things, because, like usual, I found nothing relevant.

for alpha, make sure you have “Ztransp” selected in the material settings for that texture

Captain Oblivion,

Here are examples for every single thing you mentioned.
(Press P to play!)


Thanks for the file, the tracking and alpha worked, but when I went to look at the texture, I discovered that there was no texture (???) and the armature still did nothing.
I’m using blender 2.41, by the way, in case this makes things different.
thanks again for the help, though.

Was the armature not looking like this: ?

Bending like that constantly???

It does on mine, and most likley on everybody else.

I made it on Blender 2.41.

Using armatures in Blender GE explained as quickly and simply as possible:

  • Rig your character
  • Create an IPO for the armature in Pose mode
  • In IPO Curve Editor: click the little running guy button next to the IPO type to “include IPO in action”
  • In the Action Editor screen: You will see your action. Name it what you want
  • In Game Logic [F4], set up the logic bricks so that some event triggers an “action” actuator. (Make sure you are working on the armature’s logic bricks because armatures are the only thing with an “action” actuator.)Let me know if you need more detail.

In the Blender Game Engine, you need to UV map on all your textures (I think that changed in blender 2.40+ ?). You can find UV mapping tutorials all over the place, and if you are going to make games, it is best you learn it.

This UV Mapping Tutorial is old, but it should work the same. Note, not all your textures need to be greyscale w/ vertex painting.


I changed to the blender 2.42 test so I can use bullet, and all the stuff started working, so I’m very happy. :slight_smile:

if your texture is using alpha (targa or png) you simply have to selct uv/face mode and selct the option called “face” and then simply copy “draw mode” it will put the transparency on the game engine.
beware of the redoing everything in uv mode… i was told to do so but it is not ALWAYS necessary.

on top of screen check if GAME and use blender materials is activated!