Speckled material problem.

Hi All,

Having trouble finding a solution to the problem in the pic below. If you see the two speckled split rings, they are using the same copper material as the large loop in-between the two magnet poles. No matter what I do I can’t seem to get them to render properly. I’ve tried flipping normals and that dosn’t seem to work. Even when I change the material to one of the others in the scene it still has the same speckled effect. I’ve checked and there are no textures assigned. It also seems to appear on a few faces on the main axle support. At first I thought this bit was shadows, maybe due to the AO being used but it doesn’t seem to be that.
The only difference with these parts of the modelling is that they have had a fair bit of editing done in edit mode.

I am a novice and this is my first project.

Any idea’s???.

Thanks for any help anyone can give.

Select all vertices and use W / remove doubles

Thank you Richard.

That solved the problem for the slip rings but not the faces on the main axle support.
I know this is a problem with the way I’m editing so could really do with some advice.

I’ve put a screen grab and a render below. The two loops were added by loop cut and slide so I could extrude the supports for the copper rings. As you’ll see i didn’t do this for the second set as I just created duplicates and slid them along hence no weird speckle by the second set of supports.

Would really help me if I new what I was doing wrong to avoid further occurrences and to remove the remaining speckles.


when you see such speckles, it means you have two meshes occupying the same space, so probably you accidentally duplicated your mesh in edit mode. it is called ‘z-fighting’. If you accidentally duplicated in object mode, the same thing will occur, but, of course, remove doubles will not work. So just delete the duplicate object.

Thanks Modron.

I couldn’t find any duplicate object in the outliner but selecting the faces between the two loops and deleting left a single loop and the speckles didisappeared. I guess I need to do some low res renders a little more often to catch any problems sooner whilst modelling.

The help is much appreciated.

also, if you get ugly blotches on your mesh, it is sometimes an issue with your normals facing inward instead of outward, while using the subsurface modifier in combination with ‘set smooth’. ctrl N in edit mode usually fixes it.