SpiderMan has Jagged edges once rendered with HDRI - Blender 2.9

Hi all,

Hope all is well. I’m new to this forum and thought it was time i joined to expand my knowledge further with Blender.

I’ve been using Blender for animations and really getting to grips with the process.

I’m still learning about rendering and lighting and found HDRI gives a more realistic feel, however…

I’ve finished my latest project and I’m wanting to use an HDRI with a high sun, blue skies, and minimal clouds, but when I render, the result comes out with these very harsh shadow edges on my model. If I select the render preview before rending, there are no harsh edges and it looks how I want.

Apologies if this has been asked a few times, so if anyone could help that would be great.

Using Blender 2.91.2
Render Engine - Cycles

Many thanks

preview uses eevee which is a raster engine, while cycles is a path tracer so it shows all those sharp shadows that can easily get softened by shadow map resolutions in preview mode. is the sun a dedicated light or is it solely hdri? if it was a sun lamp you could adjust the radius for softer shadows in cycles. if its all hdri, i’m not sure. i know there’s a new shadow terminator option but it might not work with hdri lighting, either. also if you’re happy with preview mode you could always render with eevee as well!

Hi Shteeve,
Yeh its solely HDRI lit.
I’ll have a play with the sun lamp and see how that pans out.

Appreciate the help and advice :slight_smile:

If you go to “object properties” tab, under shading you can set the “shadow terminator offset” to get rid of those shadow artifacts if you don’t want to use a subdivision modifier on your model.

Yeah, just to cover the basics:
You are using Shade Smooth? How many Samples and what Denoising? Can you post a wireframe? Any modifiers?

Even better can you post an EEVEE render?

Showing what I’ve said before. You can do this or you can use a subdivision modifier to smooth a bit more the surface of your model, since I suppose you are already using shade smooth.Use the lower value possible here, just enough to get rid of the artifacts, or your model will look weird after that.

1 Like

Yeh I’ve just tried the Shadow Terminator and theres no real change. But good to know for future reference though. Appreciate it :slight_smile:

Also give a look in you “normal maps” values if you did not put higher values than you should. Sometimes normals mess up a bit like that if not properly set. Make a test without normal maps.

Yes! We have some progress. Looks like the values weren’t correct. I played around with some values in the normal map and its smoothed out all the jagged edges.

All part of the learning process. Thanks Calandro.
And thanks to everyone with their advice :slight_smile:


I am really glad to help.

Oh, and if you don’t mind, can you mark the answer with solved? Thank you in advance.

1 Like