Spline Rig Issue

Hello, I’ve been experimenting on using a Spline IK to control a Spine of a character, but I’m running into an issue and I have no idea what’s causing it.

Basically, I’m using two armatures, a deform one and an IK one. I added a bezier curve and properly aligned it to the Deform_Armature and added Hooks to the Curve to control it, I also added constraints on them so they can be controlled by the IK Armature. I then added an IK Spline constraint on the Deform Armature.

Now, the Pelvis bone, moves as it should, but the last two upper bones don’t, the Chest1 and Chest2 aren’t behaving correctly. Look at this screenshot to see what I mean:

It looks like it’s shrinking or twisting the Armature in a very weird way. I’ve tried redoing a couple of times and trying different things but I can’t really see the issue and I couldn’t any answer online either.

Here is the blend file:

Spine Spline.blend (1.07 MB)

look at your curve and you will see what happen

I have looked at my curve and I still don’t know what happening. That’s why I came here in the first place…

In my view the spline ik just followed the bezier curve correct but the hooks to the curve handles are strange connected, thats what i tried to say with “look at your curve”.

I reconnect your hooks, checked y stretch in the ik spline constraints panel and added another empty.
Maybe this behaviour (attached file) is what you expect but it would be better to use bones instead of empties to get a pose position.


Spine Spline-2.blend (1.08 MB)

Thank you. That is exactly what I wanted to have, but you said it’s better to use bones instead of empties?

So, I should of parented each handle on the Curve to the Controller bones instead? If that is a simpler and better method, I don’t mind trying that out.

Oh nvm, I misunderstood you. I’m not going to use the actual empties to pose, I’m going to add bones for them to make it easier.

haha yes thats right

Sorry for bringing this up again but I tried redoing what you did on my side today and I’m just not getting that. I’m having that same weird issue.

I tried mimicking what you did but to no success. Could you explain me in more detail what exactly did you do to the curve to fix my issue? As far as I’m aware, I have it identical to what you have, but it’s not working for some reason. :\