Split 3Dview with different object mode?

I’m editing an object in edit mode, but somehow the mesh is distracting, especially when trying to fix some pinch effects or creases. I constantly have to enter/exit edit mode which is becoming tedious. So I tried to split the 3d view in order to have the same object in edit mode on one side, and object mode on the other side. It doesn’t seems to work the way I’d like, although I could swear I’ve seen a tutorial doing it a while ago. So, is there a way to accomplish this?

Thanks for reading and possibly having a solution.

You cannot have the same object in object mode in one window and edit mode in another. You can for different objects.

Why do you need to see the same object in both edit and object mode.
What do you mean by the mesh being distracting ?

Please show exactly what you are doing and what you are ultimately trying to achieve

i too agree that the wires can interrupt the shading of objects, but you just need to deal with it.

use the tab key to quickly switch between modes. if thats still too tedious, then maybe 3d modelling isnt your thing…

i suppose you could try setting the other viewport to rendered. then the computer would be complaining about tedious.

This works fine, but it soon becomes laggy, so you need either a decent card or work on simpler models.

You can disable overlay helpers by going to the N-panel > Shading and enabling

Textured Solid and

Then on the same panel, head down to Mesh Display (only visible in Edit Mode) and tweak the overlays to your liking.

The overlay settings are contextual and will only affect the region they were enabled in, so you can have one 3D view with the overlays enabled, and another with them disabled.