Splotchy Render

Hey all,
I am pretty new to blender and I was working on this tutorial but when I render it, the render shows up all splotchy.I have tried playing with all the settings but not sure how to get rid of this mess. Can anybody help me? When I switch from object mode to textured mode, it looks pretty normal, it’s just when I render it out.


The first things to do:
Check you haven’t duplicated your object so you have two objects in the same location.
Remove double vertices - select all vertices then W / remove doubles
Recalculate face normals - select all vertices and Ctrl+N

thanks for the info. I tried removing doubles and I recalculated the normals but my render still looks the same. I figured it would have to be some sort fo render setting. I started playing around with any setting that I could and to my suprise, when I turned off the Shadows in the Render->Shading section, the issue went away. I wanted to know why so I started playing around with other settings. I am still not exactly sure that causes that but maybe something with the lighting?? After adding 2 more spots to the scene, now I can turn the shadows on and its ok. Oh well, I’ll keep playing and eventually I will find my shortcoming. Thanks for the great tips though. Those 2 will be in my regular arsenal going forward for sure.

make sure you don’t have 2 objects, occupying the same space
Those kinds of artifacts are always (AFAIK) caused by overlapping faces.