Spot light issue

I posted my problem on the modeling forum, but was not able to solve it. I think I may have posted the issue in the wrong place, hopefully I can get some help here! I am trying to use a spot light with a halo to model a laser beam pointing to a specific spot on the earth. My problem is that the light seems to stop when it hits my sphere. I have the end of the light pointed to a spot on the face of my earth, but the light doesn’t go on top of the sphere it stops when it hits it. Someone suggested it was because my cloud layer was transparent. This is not the cause of the problem, because even when I remove my transparent layer, I still cannot get it to work. Any help would be greatly appreciated. I have included an image of my render to show the problem.

Remember this…HALO is a fake. If you are looking for some kind of color or light dispersal upon contact you will not get that from a HALO spotlight. But you can fake it with another sphere and an animated texture that is synchronized with the light contact. Consider it a two-step process.

I am really new to blender, and not very good at it : )
I don’t really understand what you are saying. Can you explain it in something easier for me? Where would I add another sphere? On top of the one I already have? Wouldn’t I have the same issue?

I originally tried to just insert a line that I could make emit light. I couldn’t get that to work. I then tried to insert a tube, I couldn’t get that to work either. When I inserted the tube, my instructions said to delete all but one vertex. My blender would not let me do that, it only gave me the option to delete the whole thing! That is when I gave up and tried to do the spot light, but then I ran into this problem. It seems that nothing I do works. This laser beam is a huge PITA!

Heather, as Atom said, spots in Blender are very cool, and useful for a lot of things. But they are a faked spotlight, at least when they are Halo Spots. Don’t give up.
Your initial ideas weren’t bad either.
Blender is something you have to play with, especially when first learning it. And experimentation and play are the best ways to learn. As you know.
Here’s a tip to remember when dealing with lights and things like planets that have a layer of atmosphere over another object (the planet’s surface): Even though the atmosphere looks transparent when you render it (and in the preview window, if you know how to cause transparency there, but that’s a side issue…) Blender still considers it an object covering something else.
So what you do is: Select the sphere that is the surface of the planet. Go to the panel and click the Material button (the gold sphere to the right of the triangular Object Data button), look down the panel till you see Shadow and click the arrow to expand that. Now, there is a box in that menu that says Receive Transparent. Check that.
Do the same for the Atmosphere Sphere covering the planet (if you set your model up that way (which is the standard way of doing it at this point)) and do the same.
Now your planet will behave itself a little better.
Now, make another red spotlight laserbeam, just like the other one you made (and keep the Halo one right where it is. Don’t delete it. You need it.) You can do this by selecting the Halo laserbeam, then hitting Shift-D. Then, without moving your mouse, click leftmouse.
Go to the Panel and click the spotlight icon (it looks like a spotlight), and uncheck the Halo box.
Now, your (fake)laserbeam should be doing what it’s supposed to. Just don’t assault any Jedi with that. It will end badly for you.
If you want to be moving your laser around, add an empty near them, select both of those lasers (select, and then shift-select the other), then shift-select the empty, then hit cntrl-P. Congrats, you can bash your lightsaber upside the head of any misfortunate planetdwellers you please. (Look out for those pesky Jedi. They hate that sort of behavior.) by just moving the Empty around.

EDIT: Actually, hold up a minute. Hey Atom, I have Alb’s Fastest 2.59 Build 40841. Experimenting with my advice while I typed it, I just noticed something very peculiar: My halo red spot is actually illuminating the default cube. I’ve tried everything. I deleted the other lights in the scene. There’s no IL or EL. Yet, from what I’m seeing in my very default Fastest scene, you don’t need a second spot anymore. The Halo is doing what it’s supposed to. I switched to no shadow, buff, and ray. Same deal on all. This doesn’t look like a fake Halo anymore…
Did they just give us REAL Halos?!?!
Craziest thing I ever did saw. There’s only one source of light in this shot, and it’s the HaloSpot. As long as you have diffuse checked on the spot, it works like a real spotlight is supposed to. At least on this build… (THANKS DEVEL GUYS! :slight_smile: )

Heather: Most of that advice was probably okay, and is the old way of doing it (the Receive Transparent stuff applies still)
But what Blender are you using? Did you download it from the site? Or did you get it at Graphicall?

Adam, thank you so much for all the great info. I am leaving work now, but I am going to try it first thing on Monday morning. I really really hope your suggestions work because I am getting really aggravated with this project and am hoping to finish it soon and get back to my real work! I wish I was doing something cool with my laser beam, but it is just transmitting data, not attacking poor unsuspecting jedi (but I guess if they were decent jedi they would know I was after them, huh?!?)
I am actually using an old version of blender: 2.49. I didn’t realize that there was a newer version until I was pretty far along in my project and I am nervous to upgrade because I don’t want to lose all of the hard (for me) work I have already done.
I will let you know how it goes!


P.S. Thanks for explaining things in really really simple terms!

Well, I’m happy if it helps. So do let me know how it goes.
However, I think the problem is that you’re using 2.49. There are many great experienced Blenderheads who still swear by 2.49 so I’m not going to flak it.
But Blender has experienced some brilliant leaps forward in the past few months. And we’re about to get the definitive Blender in December, 2.6.
Look, you can upgrade and still use your files. You might get a note from Blender (this is a 2.49 file and you might loose your animation…) if you try opening your 2.49 file in a newer Blender, but it should work.
Do this: go to graphicall and get Albs 2.59.4 Fastest. It will be in 34 or 64 bits, depending on what your system is. As I noticed the other night, the new spotlights can be Halo AND act like real spots. You won’t need a second spot just to put a light on the planet. The rest of that advice does hold, though (I freaking hope.)
Here’s the graphicall site:
Now, 2.59 is a little different from 2.49, but it isn’t like moving to Mars. You might have a few things to get used to. So try not to flip out too bad. But, I think once you start getting the hang of it, you might actually love Blender a lot more and decide to do more projects with it. It’s great stuff.
Though, if your scene is almost finished and this is a time-constraint thing and you just wanted to know how to get your laser working, try the above advice to finish it up and get your life back.
At any rate, good luck, and let us know with any questions you have with making the move to the new Blender. :smiley: