Spotlight shadow not displayed as it was meant to

i’ve been following the tutorial at (great tutorial by the way), and have gotten as far as creating the spotlight and hemi for the gingerbread man. In the tutorial, the image ( shows the shadow displayed pretty much in proportion to the gingerbread man.
I followed the exact instructions, but I get a slightly different image:
The gingerman looks much more “plastic” in the tutorial (more light around the edges) The shadow is different - towards the feet the shadow is lighter and thinner, but further up the shadow is darker and much larger.
You can have a look at my render at

What do I need to do to make my render look like the one in the tutorial?

Thanks alot,

Hi, I’d say it’s either the clip start or clip end for the shadow spot. Or the spot might benifit from being slightly further away from the mesh.

If you used Ray shadows for the spot, you would have an even shadow, but with sharp defined edges.


I wrote this tutorial for the old blender3d site a long long time ago. It could be handful as it deals fully with ClipSTa and ClipEnd, as well with some optimazing parameters such as Bias and samples.

hope this helps,

it’s the too high bias setting. turn it down and rerender until you have results you like. i don’t know if this is persistent, but in 2.25 having a too low bias (maybe together with other settings i don’t remember) resulted in banded shadows.

Thanks alot for all the suggestions. I’ll give them all a go and report back.

Setting the bias down to 0.5 did the trick for the non-existant shadow by his feet, while playing with SpotSi and SpotBl gave a much nicer and smoother effect.
Thanks for the replys

:o Oooohhh…! So you’re the one who wrote that great tutorial. :smiley: “Itsa good’un!”

Now, I always get a little bleary-eyed %| about Shadeless. I guess I haven’t really grokked its effect. (Anyone?)

But I did also “discover” the usefulness of another button, (Materials:MirrorTransp:)OnlyShadow. Very handy for compositing. The shadows cast upon the material show-up, but not the material itself. (Note: I am not referring to a shadows-only spotlight.)

If you have an (eg) green material with shadeless on, then every pixel will be green in the render - regardless of whether there’s lights nearby, or if there should be a shadow cast, etc.

It’s useful for applying image textures if for composition if you don’t want any extra shading

Thanks :slight_smile: I also wrote the tutorial about head modeling using subsurf but I’m not too happy with it… Modeling capabilities of Blender and one’s skills improved since, and the head tutorial should really be re-written edgeloops-wise and knife-wise :wink: