Start frame of images sequence in node editor in image node doesnt work.

Hi got this file where i have an image node in sequence mode.

this are my settings :

-frs 250 = Amount of frames to be used
-S fra 245 = start frame in the animation, in the blender timeline in the proyect
-offs 0 = offset , if we have a 100 frames sequence, if we put 5 in offsert, the sequence will start at its 5th frame.

If im am right , my sequence should start at fram 245 in my proyect.

but it doesnt.

do you know why ?
Thanx !

here’s the file :

Hi I took a look and I am wondering about the sequence since it wasn’t in the blend file. Perhaps its not setting up the sequence right. Did you try converting the sequence into a video and then selecting the frames from there?

Rereading your post, my understanding is that the frame settings apply to the sequence itself, not your render. To just use this at certain frames in your render I’m pretty sure that you must use a time node. Please correct me if I am wrong but I believe that your setup as shown would start seq liquid from its frame#245 starting at your render frame#1. If you just want this to start at render frame #245 then perhaps you would like to do a seperate sequence starting there.

any other ideas ?

if configured correctly, it should show you the preview.

As I understand it:

-frs – just as you say, but if your image sequence starts with frame 0 be sure to add one more frame to the count to include it (e.g. 0 - 250 is 251 frames); same for other frame counts (e.g., 25 - 250 is 226 frames)
-S fra – again you’re right, this tells where in the current bender file this animation’s first frame should appear – afaik it has nothing to do with the source file frame count
-offs – this is where you’re having probs, I think. Offset was very unclear to me at first, but in practice this is how I set it: Set it to the initial frame number of your source material minus 1, e.g. if your source frame numbering goes from 25 to 250, Offset is set to 24 if you want to use the first frame of the source. Set it to 0 if your source starts @ 1, and -1 if your source starts @ 0, and so on.

Offset is very useful for determining where in the source sequence the animation begins in the current Compositor rendering. For example, If I load up source that has a frame count from 25 to 250, but want it to start at frame 30 of the source, then I edit the Offset to 29, 5 frames ahead of the Offset for the actual starting frame of the source. This way you can use the same source material in a number of nodes but alter the timing of how it appears in the render (without using Time nodes).**

The relationship between all these settings is kinda complex – the best way to get a handle on how they can be used is to do some test runs and edit each value one at a time, with a test render to show the changes. Much clearer than a verbal explanation.

**Edit: I realized that this may be a misleading (though true) statement. While editing Offset can change which frames of a source appear at any certain point in a composite render, you still need to use both S fr and Time Nodes to establish that certain point, i.e., where in the render they are supposed to appear. The Time nodes control whether or not the input “pipeline” is open or closed.

the preview is not a problem , it doesnt show because of a bug in mac laptops.

isnt it allready configured correclty ?
my sequence starts with a 1 for example , animation_01.png , animation_02.png , animation_03.png and so on.

so where is the problem ?


Your offset value probably doesn’t take into account the frame numbering of the source image sequence and it needs to.

Edit: Sorry, missed the info about your Image Sequence numbering – it seems that your Offset setting should be OK if it starts with 01. Not sure what the problem is, then.

so anyone knows ?


Hey, TK. Took a look at your file, but the Image Sequence (starts with liquid0001?) wasn’t packed with the rest of the texture stuff. I’m not sure Image Sequences are included in Packing, since they can be quite large at times.

Anyway, if you can upload that in a zip or something I’ll try again.