static particle issue

if this has been answered before, forgive me, but i did a search and couldn’t find any.

I have a mesh emitting static particles (fur) parented to an armature set-up. static particles are set to animate, emitter is subsurfed, everything’s good, but when I move any part of the armature structure, the particles lag behind. Basically, as any part of the body moves it leaves a trail of particles behind and it almost looks as if he’s shedding is fur.

Any help would be greatly aprpeciated. Thanks.

that should be possible in 2.34
[link was horribly wrong before]

I have Blender v2.34, and i think you mistook my problem. The problem is that he does shed when he moves, and I don’t want him to. Does anyone know why?

The particles [b]ARE[/b[ supposed to lag behind, it’s the new improvement. If you don’t like it, you could probably make your halo material shorter.


Hey arowe
Can you tell me how to the get the particles to at least move ?? I have 2.34 and my particles won’t move at all they stay at the same spot and never move! Your problem is my solution!

um, well, my particle set-up is pretty simple. If you mean you want a group of stationary particles (as in a thing of hair or grass) to move around, then press static, animate, and whatever set-up you want with the rest of the settings, but you have to make sure the particle emitter is subsurfed. The particles won’t update themselves on the screen when you move them(unless you press the RecalcAll button) but they will when you render. Or should.

Sadly, no solution to my problem. Oh well:( Though I don’t see how lagging particles are an improvement

They lag because thats what hair does when you move it fast. You swing your head, and (if you have long hair) it lags behind.


That’s not the lagging I mean. I mean the hair actually physically comes out of the body and then just hangs there floating in mid air and doesn’t swing back. And the further the body moves, the more hair that comes off.

hmm, never had any problems so far with it, at least not like what you describe. a pic or .blend might help if its not for some secret project ;). Maybe settings or something so we could try and recreate the problem?


actually, I just had a weird idea. Static particles are usually drawn as multiple particles. In rapid movement, this might give the appearance of shedding (since some of the particles may seem detached from each other). Thats a pretty tenuous assumption though. In any cast, try setting the Steps option in the particle options to 1. The static particles should now be drawn as a solid line. I don’t really think that will solve the problem but its worth a try I guess.

I’m sorry I can help you either Arowe but I still can’t even get the static particles to move at all even after sub sufing and recalculating the particles. I am either doing somthing wrong still or could this be a mac specific bug? Anyone else using mac OSX 10.3.5 and tried this? Hey Arowe, do you think you could send me a small blend file witht it working? Somthing real simple.

My email is falcon(at)earthed(dot)ns(dot)ca
That would be really great if you could!

I don’t know if this will help any of you but I have found a little quirk so far. Before when I parented my arm to the armature I always used the armature setting as opposed to the bone or object ones because I had multiple bones to animate and it never worked. So then I tried it with just one bone using the bone setting and it works perfectly. So it appears to me that using this armature setting along with particles and animation doesn’t work right in 2.34, maybe just the mac version, not sure. I am not sure if this applies to you but maybe someone else could try and reproduce this. it would be much appreciated

I haven’t had any problems, using the bone or armature. I’m on XP though. Don’t have a Mac so can’t test it on one.

I am not sure if this will help or not, but just a thought…

If you are previewing the particles in the viewport, then they will look like they are left behind, since they are not recalculated after each frame when playing the anim in the viewport.

So, try rendering to an avi and then see if they are updated.

This is because the animated particles are only recalculated at each frame at render time.

If I have confused anyone, let me know. I will try to make myself more clear.

No no,
I have tried rendering to no effect as well as pressing the recalculate button. If I use the armature setting it just doesn’t seem to work. Hey sdk1, even if you are on a PC or anyone else could you maybe whip up a quick test blend file and make sure it works using a couple bones and armature and send it to me at the address i gave above in the post. I really want to nail down if this is a mac bug or something.

here’s the blend file, so you can see what the problem is:

I have tried playing with all of the settings, and always pressing the re-calc button every time, or rendering the frame, but the problem remains. I hope one of you can figure out why after seeing the blend.


It is a problem with your vertex groups.

Some of your vertices are not assigned to a group, so they do not move with teh armature.

To see what I mean, select your fur mesh, and delete the particle effect and turn off halo in your materials. Now look at the mesh as you move the arm. Some stays behind.

That’s your problem.

BTW, cool character. :smiley:

:o I never noticed that. Thanks alot! :smiley: