Stop Player From Going Through Plane

So, when in the game, (Note: I’m using planes for walls) if I walk into
a wall, the character usualy just goes through it. It really brings down
the game in terms of reliability, and professionalism. I mean, how fun is
it to fall out of the map and fall infinetly?
Yeah, well if you can help me out, it’d be nice! THANKS! :RocknRoll:

If your using simple motion i’d suggest switching to servo control motion. Other then that are your walls separate from your floors? if so maybe set the collision bounds for your walls to box and increase the margin settings to a 0.05 or 0.1. Hope that helps:)

1- I’ll try Servo Motion
2- The walls are seperate from the floor
3- I tried it, but to no avail. It goes through even more easily than before.

I also suspect using “loc” rather than servo motion is causing the problems. If you want to know why, it’s because “loc” teleports 60 times a second in the direction you want to go.

Alright, so I switched everything to servo, but I HATE how it feels. Is there a way to suddenly stop the movements instead of sliding?
When your running, It’d be pretty dumb if you attempt to stop but slide right into the enemy.

i use distance constraints to not go through walls.

Have a look at They have a good tutorial on it.
What they do is have another logic brick that stops you when you aren’t pressing a move key.