Strange Ambient Occlusion reaction with Pantin Rig

So I’m using the Panting rig for a scene, but when I turn on Ambient occlusion (settings are Factor=1.00 with it set to multiply) it turns Pantin’s Eyes a glossy black color. Not what I want. When I set AO to add, the eyes can be seen again, but the lights are all out of wack. Is there some way I can manipulate the settings of the rig to work with AO set to multiply?


Also, I turned off the emitting properties of the materials, if that helps.

Downloaded the rig, turned on AO and the eyes don’t go black. If there is something with your settings who knows as you haven’t supplied your blend.

Right. Sorry, here you go.


Scene.blend (730 KB)

In your model you have cornea objects in the eyes that are set to be invisible but renderable. These seem to be giving the black AO rather than the visible eyeball. I have seen in the past having problems with raytraced AO with transparent objects. Changing from raytraced to approximate AO should work.

Edit: For the transparent material used by the corneas turn off traceable in the material options so it is not affected by raytracing (render below by just doing this change)


Thank you!