Strange Behavior in the Sequence Editor

After placing some audio files into the Sequence Editor, I realized they weren’t set to relative paths. And I like to keep all files relative - there’s hardly a case where it isn’t preferable; it makes for a more flexible pipeline.
So I ran the File > External Data > Make All Paths Relative command. I saved a new file and reloaded it - the audio no longer played at all!
When I inspected the properties of the audio strips, I was a bit surprised to see this : to enlarge

Clearly not a normal file path. I tried clicking on File > External Data > Recover Missing Files and found the file - but it didn’t change the path at all! So I manually found the correct relative path, by typing it into the field in the Input panel ( too bad it doesn’t have a file requester there ).
But I’m unsure what prompted Blender to link it to such a file structure. Is this a bug? Or am I missing something?

confirmed bug Windows Vista Blender 2.48. I loaded a blend file, and added an audio file from a subdir as absolute. File-External->Make all Paths Relative gave me jibberish in the Input panel. Please report to bug tracker. I just pointed out another bug somewhat related to dots in the filespec, but this is a variation on that, looks like. Attempting to convert back to Absolute gave me nothing.

Loading an audio file relative, and then attempting to convert to absolute also fails.

Ok reported it to the bug tracker.
I included a link to this thread.