Strange global pivot behaviour. Bug?

using 2.57, start a new scene, select the cube, MMB, and the view is in turtable mode, all is well.

Zoom out, move the cube out side the grid, use the Snap functions (SHIFT+S) to snap the cursor to the cube, rotate around a little.

Now…here it comes… snap the cursor back to the center of the grid, then select the cube, then snap the selection to the cursor.

Turntable view mode does not work any more after that.

is there a way to reset this? I toggled the turntable buttons on and off several times in the user preferences menu, no success


I may have misunderstood your post, but I believe that there are two solutions here:

  • Press the Numpad-dot (.) key. This has the side-effect of recentering your view around the selected object… which may or may not be what you’re looking for.
  • Enable Rotate Around Selection in User Preferences (Ctrl+Alt+U, Interface, View Manipulation->Rotate Around Selection). The side effect here is that you need to have that cube selected for turntable to work properly.