Strange grafic problem: background image, curser, ipo keys

I am very new to Blender and that is why I don’t know if I have got the problems because of settings in Blender or if something is wrong with my PC.
It is really strange:
After positioning the cursor over anything for several seconds an yellow pop-up appears with a discribtion of the certain object…so far so good…when I move away and the yellow face disappears, it reveals a black area OR a piece of an IMAGE!! I can’t really discribe the image because I always see only a small part, but it is red with several creatures…This happens everywhere in blender… It also happens when I use Hotkeys as SPACE or IKEY.
Annoying but I was able to work with it…
Box and Circle selection: I don’t see the border…It’s impossible to use the circle selection…
Keys in Actionwindow.
I made a tutorial on Lattice animation. Everything worked alright, but I don’t see the keys in the action window…They exist because when I play the animation the ball moves exactly as it shall, but there ar neither sliders nor keys on the left side of the frame display…I now don’t know how to delete a key…I can’t select it.
Pls give me any hint how I can change these errors.
I experience Blender as a mighty and smart structured tool, but I can’t properly use it…

can you give us more details to your system specs (graphics card and driver and settings in particular). As well - what version of blender, what OS (Win/Mac, etc), if Vista, is aero on?

It’s probably from the last video cached to your computer that you watched. It’s like it stays there behind everything else. Reboot and see if it’s just black, then watch some video and see if it changes.

It’s probably a disagreement between your graphics card driver and openGL. Do you have the latest drivers (Unless it’s ATI, in which case, just whichever makes the problem go away) and do you have any desktop effects that might not agree with OpenGL?

What is your system anyway?

Thanks for your quick reply!
I have got a Thinkpad notebook. X300…I know…not the best for grafical design…but it is all I have till now.
It has got NO grafic card.
Processorfamily : Intel Core 2 Duo
Processormodel : SL7100
Processorfrequency (GHz) : 1.2
RAM (GB) : 2
???: DDR2-667
Chipset : Intel GM965
Grafic chipset : Intel GMA X3100
The operating system is Windows Vista.
I don’t really know where to look for drivers…are there any if there is no card???
I don’t think it has something to do with cache…First of all I never saw this picture before!!! It looks like a blender creation and it is always the same.
I will try to supply you with screenshots…
Thanks again. Looking forward to hear from you

Okay I managed to make screenshots of parts of the images…by the way, I downloaded the 2.49 version. Same problem different image…![file:///C:/Users//Pictures/screenshot%20blender2.jpg](file:///C:/Users//Pictures/screenshot%20blender2.jpg)


Did really nobody see something like this???
I now found out thad the image does change…right now I had a really strange picture of the things I was working on…Have a look at it… Everything within black rectangles is not supposed to be there…


I just tried with vista aero disabled. No differnce. By the way I use the newest version of blender(2.49).
Still hoping for hints…

Anything linux or linuxesque (like blender) is going to take small issue with the combination of Intel IG and Direct accelaration. I don’t know why but it’s the common occurence. Sometimes it helps to disable direct draws hardware accelaration while using Blender if you’re using an Intel graphics accelarater driver. It doesn’t slow it down; heck it may not even need it. Microsoft signed drivers work extremely well with Blender. If your vista disk has one on it ( I’m almost positive it does) you may want to go that way.

Thanks a lot blonder.
I am afraid I am too stupid.
I really have no idea what “combination of Intel IG and Direct accelaration” is.
If you are by chance german, you maybe could translate it…Maybe i get an idea then.
Otherwise I will set blender down for a while…I’ll be soon at an university i am sure i will find someone who understands what you wrote.
Nevertheless…Thanks very much again!..In the end I will solve the problem :wink:

I’m sorry I’m less than 1/4 German and speak almost none. You write English so well that it seemed to be your first language. I’ll be more clear.
It’s your onboard graphics. The problem that shows on your screen is called tearing. The program that is having problems with your Intel GMA (Graphics Media Accelarator) driver is called DIrectX. It has two different subprograms that help Windows to use your graphics chip. They’re called Direct Draw (2D) and Direct 3D. Direct Draw has support for your graphics chips accelarator but the driver from Intel for some reason doesn’t work as well as the Microsoft drivers that are installed with Windows. You should have a driver that will work well with Blender in your computers driver database. It should be called something like
Intel GM965 video driver (Microsoft Corperation)
Intel GMX3100 video driver (Microsoft Corperation)
The problem with these drivers is they don’t support video games. Most graphic artists enjoy a video game. IG or integrated graphics just aren’t that good for graphic arts. I’m pretty sure that the Microsoft driver will fix the problem.

Hi there,

I am new to Blender too and faced same problem in Vista.
Here is how I could fix it.

  1. Right click on the blender.exe
  2. Go to properties
  3. Click Compatibility tab
    ---------- Check [Run this program in compatibility mode for : Windows XP (Service Pack 2)
    ---------- Check [Disable desktop composition]
    ---------- Check [Run this program as administrator]


Run Blender…

:smiley: It works with border selection marker

Thanks a lot! Works fine!
I will have a look on the first solution later… It seems to me too complicated…

On the Blender download page, it states on the right side “Users with Intel on-board graphics: some graphics operations (menus or border select) don’t show due to driver bug.” Background photos and the about screen will leech through portions of the menus due to this problem. Border select doesn’t work either. I am running on Windows Vista Home Premium 64-bit HP Pentium Dual Core CPU with 4 Gigabytes RAM. Intel G33/G31 Express Chipset Family (integrated graphics). To find this on vista go to Computer>System Properties(top bar)>Device Manager(left sidebar)

In Device Manager click [+] on Display Adapters and that is your graphics card below. Double click your graphics card, go to Drivers, and you can update it from there. (Windows will search for an update)

I have the same problem with my computer and Blender 2.49a, I tried “jacksparrow”'s idea to fix it (changing blender.exe shortcut’s properties) which didn’t do anything. For the time being until I go buy a new graphics card, I will be stuck without Border select *and sadly GLSL shading for games as well :frowning: )

Happy Blendering!