Strange Particle Behavior

Ok, contrary to what you probably thought when you clicked this, this isn’t about the new particle deflection. Here is an image of two burning astroids I need for a project.

Notice the bottom one doesn’t have the flame. The flame is there, but it is actually being covered by the smoke. The problem is, even if I bring the flame way closer to the camera, where it would obviously be in front, the smoke still covers it. The even weirder thing is that the bottom one is a duplicate of the top one. I just Shift-D’d and moved it down. Anyone have an explanation?

Here’s a little more clarification too. This is what the set up looks like. The pink highlighted one is the fire. Somehow, I didn’t get the camera in there, but it is at the bottom of the layout there.
As you can see, it is much closer to the camera than the smoke, but here is what the render of that looks like.
Anyone? Glitch in 2.34?

I have no explaination, but maybe a suggestion to fix it.

You could try duplicating the duplicate.

I have found in other programs, like Autocad, this can work. Never tried it in blender though.

Anyways, just a thought.

Render with the Unified render turned on (Scene Settings).