Strange problem with progress bar in cycles. Not showing amples

I have a problem with the progress barr during rendering.
Normally it should show how many samples are already rendered.
But on my computer there’s no such info. It dissapeared and I don’t know why.
But when i turn the Cpu rendering it works. It only doesn’t apear during GPU rendering.
I used the same build (official 2.64a) on other machines and there’s no such problem.
Can u help me? it’s driving me crazy.

I attach 2 images to illustrate the problem. The one without red circle shows that there’s no sample info.

Hey does any one know nothing about this issue/bug?
Maybe I should ask someone from the developers? Do you know how I should do it ?
Please help

Hey. I noticed that the problem occurs when I use 2 gpu’s. When I disable one the samples snap back again.
Maybe it’s a bug or what ? How can I report a bug ? I never done it before

Cycles is now tile-based, meaning, like BI, it renders one tile until it’s done and then moves onto the next tile. If you’ve got more than one rendering thread (more than one GPU or more than one CPU core) then more than one tile is rendering at one time - so it doesn’t show you the current sample progress because there is more than one :stuck_out_tongue: one tile might be at 100 samples while the other is at 200. If you only have one thread rendering, then there’s no problem showing the progress.

And yes, it would be nice if it showed the progress of all the tiles :stuck_out_tongue: The progress bar at the very top does show a sort of average progress, so that is useful at least.

But tiling is siet to x:1 y:1 so there’s only one tile.
When I use one GPU or the CPU (8 cores) samples are visible even when tiling is set above 1. Only using two GPU’s causes the problem so it’s not becouse of tiling (i think).

I’m guessing that doesn’t matter. When deciding whether to show the sample progress, it doesn’t care how many tiles you use, only how many threads you’re rendering with (1x1 is a very bad idea anyways, the new system makes that very slow, but with more tiles it renders much faster than the old system). Maybe a dev could add that check in first, but that’d be a waste of time and effort (and add another step, slowing down the render) since no one in their right mind would render a 1x1 tiles image anyways.

Yeah but when i do a preview render with two gpu’s a see the samples.
Any way I don’t really understand that problem. I need this function becouse when I render I set a huge amount of samples I then I abort when I get the image satisfying. I can’t use tiles becouse they render to the full amount and then it switches to another tile.
Isn’t there any help for this issue ?
P.s And I don’t really see tiles make things go render faster. They are useful for big resolutions but usually I don’t use them (Don’t have to guess how much samples I need to set up) .
P.s.s I didn’t realize that such a small thing could be so difficult to solve.

The preview render is one big tile, so it has no problem showing the sampling.
I had the same workflow as you, but now I’ve been working with the tiles for a while, it’s much better and quicker. Basically, in the viewport/preview render you see how many samples it needs to clear up, then that’s how many samples you tell it to do.
This thing whole tile thing isn’t a “problem” as you say, it’s a solution. It allows fast rendering of huge scenes, since the GPU/CPU only has to render bits at a time, whereas if it had to render the whole image like it used to it would run out of memory quickly. The whole thing would render slowly because one piece of the image needs more work.

Sometime soon (might be there already, I haven’t actually looked) we’ll get a feature that allows us how many samples we want to specify for each tile, since certain portions of the image don’t need 100000 samples, but that little piece of glass with caustics in the corner do.

That’s as much “help”/advice/explaining I can give you. If you’re too stubborn to accept change and blatantly deny that it’s for the better, then fine, use an old version if you want.

First of all it’s not polite to characterize people as stubborn (If you think that leave it for yourself)
second thing you said “The preview render is one big tile, so it has no problem showing the sampling.” The render is also one big tile and it doesn’t show the render - no logic in that.
third thing tiles are good but the problem is about showing progres of a render, and that’s a problem for me not the tiles (they are a very good feature). If I enable them(tiles) I still don’t see the samples when using 2 gpu’s, but when I use one they are showing up and that’s it.
If there is no posible way to do show them when using two gpu’s, that’s too bad but I’ll have to live with it(it’s not the end of the world). I thought that was easy but probably it’s not. too bad

Just noticed last night, in the Performance panel of the render settings, there’s a checkbox near the bottom “Progressive Refine”. The tooltip suggests that’s exactly what you want :slight_smile:
If you don’t see it there, you may need to get a newer build from

Ok thank’s for the tip. I’ll try that when I get back home. Hope it helps (excited :slight_smile:

YEAH! the “Progressive Refine” checkbox worked! thanks! that’s a life saver! Thank again and cheers.
think the topic’s closed now.