Strange shading on basic planar model

Hey guys, I’m new to the forum. I’m a hobbyist blender user and lately I’ve been making mock photo shoots of products we print at my work (I’m in prepress in a 2d commercial print shop). Ultimately I’ll be using the renders for our website as I currently don’t have the budget or space for an actual photo studio.

Anyway, my problem which I’ve never run into before is with a booklet I’m making which is basically a plane with a few subdivisions along the Y-axis and manipulated into a curved shape. I’ve added a subdivision surface modifier to help curve it out even more, then after that a solidify modifier to simulate paper thickness. Here’s where the problem is, the shading on the model gets funky (see attached screenshot). Which this goofy shading is causing the render to behave funny (see attached quick render).

Anyone have any ideas how to fix this?


It is caused when the mesh is set to “smooth” rather than “flat”. The edges are also trying to be smoothed off as if they were round.
Try setting back to flat shading (from the settings bar on the left in object mode).

In simple Terms,add a edge split modifier. If this is causing other faces to act weird then select the edges on the outside of your book at apply sharp edges (on the left side,shading and UV tab) along with unticking edge split angle on the modifier tab, you may also have to mess with the order of the modifiers so that edge split is applied at the right time.

What’s actually occurring is that since your faces are all Smooth its trying to keep a smooth curve on the solidified edges,which are of course a almost right angle to your actual paper mesh, lighting heart attack ensues as it cheating it by making your lighting look curved.

mmmm… With subdivison surface and solidify. i will just add some loops on the border the pages… could be caused because you have only vertical loops … Even when using sharp edges sometimes with solidify it is needed to give it a bit more of control.

Ah ok. Thank you guys. I’ll give those a shot.

Yep for book pages I would do your basic shape as a flat plane, then add as subsurf, then UNDER that add a solidify, then under that add an edge split, and set it smooth. You should be able to adjust the edge split angle if you are still getting any errors.

Or… Instead of edge split do:

loop cuts around the edges

smooth shading

subsurf and solidify modifiers

and then use auto smooth (see screenshot)

I usually activate auto-smooth on the object geometry tab and set the value to 30 or 60 depending on what I am after.

You guys are great! The edge split modifier worked perfectly.

Here’s a test render so far…