Strange shading over some edges

Hi

I have noticed this issue a few times and thought i might as ask if people might know what it could be.

I am following video tutorials and my topology seems to match but on the video they dont seem to have this strange shading issue.

Could this be due to my graphics card?

I have attached an image of the issue

Thanks :slight_smile:


Look to me like an issue with the subsurf modifier: Concave areas may hide the underlying mesh. You might also want to check shading smooth/flat.

Thanks

When I smooth shade I do have to sort the normals out but once they are sorted it seems fairly smooth :slight_smile:

Just a nightmare when trying to keep my poly flow the same as the video

This may be that you have dupe vertices over each other, yet they both are connected to the neighboring vertex. Could be wrong. But, what I do when I see this is vertex select and move (grab/move) to see if there’s another vertex underneath, if so I delete and reconnect.

Doesnt seem to be any vertices under it, when I zoom in they appear but when im zoomed out they are not there (which is why I thought it was a graphics card issue)

Have you tried enabling the ‘Apply modifier to editing cage during Edit mode’ option in the subdivsion surface modifier

Ah thats sorted it - Thanks a lot Richard :slight_smile:

I’m having the same issue while doing the same tutorial. And in that tutorial the ‘Apply modifier to editing cage during Edit mode’ in NOT enabled. When i open the demo .blend files provided with the tutorial, the mesh is perfect, but i can’t get it to look like that even if i try. Could there be some other option enabled that we are not aware of???

Give a link to your blend file that shows your problem (you can upload it to http://www.pasteall.org/blend/)

I JUST SOLVED IT!!! the problem was in the view clip end distance. By default it was set to 1000. In the source blend file it is set to 5000. Therefore, the solution is:

  1. Open the 3d view right panel (mouse on 3d view, press N)
  2. Scroll down until you find “view”.
  3. Under “clip”, increase the “end” value until the weird shading goes away

Cheers!