Suddenly Can't See Anything

I was working on an object and moved back from it, which took my viewpoint into another object. I’ve had this happen at other times and when it does, I find it hard to “get out” from inside any object. Zoom, pan - any camera movement goes extremely slowly when my viewpoint is in another object. This time it’s worse. I moved into an object, tried to get out, and ended up with a blank view:

The objects are still there. When I hit Numpad-0, I do get a camera view:

However, once I get to the camera view and do ANYTHING, like pressing Numpad-Minus or Numpad-Plus, the view goes back to the first image.

I’ve tried zooming out and in by using two finger gestures on my trackpad. Nothing. No indication of movement or anything else. I’ve tried moving by holding down Numpad-Plus and nothing happened. I wondered if something had happened and I zoomed out so far I had lost the view, so I tried it with Numpad-Minus. Again nothing. I save the file and re-opened it. Nothing.

Is there any way to relocate the viewpoint of my workspace to a specific point so I can start from a known location? As it is now, this file, which is the result of a lot of work so far, is useless.

Okay - I thought I had looked over everything and then it hit me, as soon as I posted, to look at View in the menu and was able to get a good view again.

Still, what’s going on when I get a screen like the first one in the post above?

Numpad-. is usually a quick way to frame your currently selected object / elements if you got lost somewhere in 3D space. It’s what I use most.

What’s going on there with the really bad slowdown is that in perspective mode Blender maintains a central viewpoint around which to orbit. The closer you get to that, the slower your zoom until it basically stops. This is useful if you orbit around a specific object a lot while modeling, it’s kind of like a potter working on a wheel. But it’s disconcerting when you end up stuck like here.

There are a number of ways to get around it:

  • Alt-MMB-click sets your viewpoint to where you clicked
  • Shift++ moves the viewpoint along with you (this is still slow, but sometimes what you want if you’re real close up to various nearby bits you want to inspect)
  • Walk/Fly mode, which is a completely different way to navigate (
  • Edit → Preferences → Navigation → Orbit & Pan → Auto Depth works in combination with …Zoom → Zoom to Mouse Position; the distance is always the value under the mouse cursor. Takes getting used to, but I like it and use it when I have actual scenes rather than just a single object on which I’m working.

There might be more.

1 Like

There are a couple of things that can cause this… very small meshes and very large meshes can do this combined with the viewport as well as the camera clipping setting…
Just setting the clipping values to .1 and 10,000 may fix it…another thing that you can do is to take it out of perspective view and most meshes will instantly appear ( Num 1 or 3 on the Num Pad ).
Some of the options are already stated but I find the HOME key the best in some situations it will give you the complete view of your mesh ( acts as if there is a bounding box around everything and fits the viewport to that box…)

Switching between workspaces or functions like Object and Edit Modes, if you set Orbit around selection in the preferences > navigation
You can use the outliner to select and the period on the Numpad to pinpoint those meshes and rotate around them…

1 Like

Thanks - there are times that’d be far less than Home.

I use a track pad, so I’ll have to look up what to use as MMB. Thanks - I hadn’t even thought of using the MMB for anything yet.

I’ll look into this so I can start using that. I forgot to mention I’ve already adjusted clipping.

The mesh I’m working with is 35mm on the shortest side (L, W, & H) and 60mm on the longest, so I don’t think size is an issue. When I’m working, my workspace is like a physical workshop. I keep parts around me - parts of what I’ve built or building, and keep parts of older versions I’ve tried until I’m sure that version is not going to be used again. So sometimes I have too many things too close. This happens whenever my viewpoint crosses over to go into an object.

I meant to mention that I’ve done this - forgot to include it in my post.

Believe it or not, I tried that. None of the Numpad keys for 1-9 worked. 0 gave me the camera view I included above. But doing ANYTHING to move from that camera gave me the “Lost in Space” view again. Usually when I go to a camera view and move, there might be a “jerk” as it’s realigned, but it moves to a view close to the camera’s POV.

That’s part of what’s weird. I toggled modes - no change. When I did find the Home key, that worked, so the problem is solved, but I’m still interested in what’s going on - so I don’t run into this in the future.

Even tried that. Weird how so many things did not work! I still have no idea if I had zoomed in too far or zoomed out too far. I guess now, I won’t know, but I hope I don’t get stuck like that again. It had me wondering if I could actually lose all the objects I had created in there. (I’m doing 3D print work, so it’s for that.) I was thinking, “If I can’t move around and select or find any objects, I can’t do anything in here - can’t edit and can’t export STL files.” It just seemed surreal and odd.

1 Like