Surface Tension & Sheeting in Flip Fluid add-on?

Hello everyone,

I’ve been baking a scene with a large ocean wave coming towards the camera.

Because of the baking time and etc, I’m baking it in Grid Resolution 300, no higher above.
The scene will look a bit low res, especially waterdrops separating to each other.
But I found out adjusting Surface Tension and Sheeting will solve this problem a bit, making the waterdrops to stay together to make a thicker surface.

There are two things I’m difficult to solve.

  1. I don’t know if setting Surface tension and Sheeting would increase the overall baking time or not. It seems pretty random but, if it increases overall baking time, I’d like to uncheck either of this setting and make the scene still look flattering.

  2. the surface gets bigger in certain frames. for this one, it’ll be frame 400~500. I thought it’s because of the camera perspective, but the overall amount of the surface is getting bigger in these certain frames! I’d like to make the wave coming gradually, and the full tide would be happening in about frame 700. Adjusting inflow velocity never works with this problem. Tweaking Surface Tension and Sheeting only made the problem worse.

I also think the surface looks to white. But that another thing I’ll have to solve after baking the scene.

Would there be any way I can make the scene work?
I’ve been making this simulation for weeks, and it’s really hard to find the right set up for me. If there are any suggestions, I’d love to try everything.

3.7 GHz Intel Core i5
16 GB 2667 MHz DDR4
Radeon Pro 580X 8 GB

I’ll also post my blend file.

Thank you!


For the surface tension and sheeting increase the baking time a lot (from 3min to 8min).

I suspect, though, that I don’t have the same settings as you. Mine looks significantly different. I don’t get that spraying to the back, left of the pillar at all.

From the POV of physically correctness, you should enable neither surface tension nor sheeting. For that used grid size, in real world these effects would be too small to be resolved on that grid.

To get good waves, you likely need deeper water. Also using an animated obstacle (to give the water a shove) might be easier to control the wave.

About the material in your render, there certainly is clipping of intensity, thus it is so white (too bright light, I’d say). What I found in the blend file, though, is transmission of the principled shader is only 0.65. That certainly is way too low. But honestly your render doesn’t look like that, only mine. Is that really the setting you used for your image?

Hello omgold,

Thank you for your advice. I will bake without any surface tension and sheeting from now on. Making deeper water and using animated obstacle also sounds right.

The surface was shining too much from harsh sunlight. I’ve decreased the overall sunlight, and it became normal again.

Thank you!