SVG's not showing up in Blender

Hey guys,

So I only downloaded Blender the other day and I’m already stuck. I need to import an .svg logo into Blender but every time I try it doesn’t show up.

I have googled the problem and nothing suggested seems to apply to my situation.

The logo in question is made up of several paths; so i tried using a simple square (drawn in Adobe Illustrator) to make sure that my issue was with the logo and not anything else (it wasn’t neccessarily the logo, as even the square won’t import). The square is literally just a single, closed path - and according to all the advice I have read so far regarding .svg’s not importing; there should be no issues with a single closed path.

  • I have tried importing an .svg square with fill and stroke, with fill only, with stroke only; to no avail.
  • I have tried zooming in after the attempted import (as I read sometimes they import very small) but no luck.
  • I have tried seemingly every single .svg type that Illustrator can possibly save as.
  • I have tried playing with .svg settings.
  • I have made sure ‘Preserve Illustrator editing capapabilities’ is unticked.

Nothing works. I have tried a variety of handdrawn shapes since and absolutely no .svg will import into Blender.

Any suggestions?

Does the imported object show up in the outliner ?
Supply a link to the blend file with the imported object

Thanks for your reply!

A lot of curves are showing up in the outliner yes - which I guess are the attempted imports?

Can you recommend a service to upload an .svg?

Thanks for the reply.

I do have a lot of curves showing up in the outliner which I guess is something to do with the imports?

Can you recommend a service to upload an SVG?

Upload the .blend file to and tell us the download link

Okay - here is the download link. The .svg I attempted to upload in this example is a simple square with a black fill. It hasn’t shown up visually but there is a curve in the outliner which I presume is it.

Okay - here is the download link. I presume the curve in the file is the .svg that i attempted to upload (a square with a black fill) - but it isn’t showing up visually.

Thanks again

Thanks Eppo I will try this when I finish work for the day :slight_smile:

The size of your object, very very small.

Scaled up x 10000