Ter2Blend problem (again)


(Detritus) #1

Hi! After some help from the Elysiun-forum I´ve finally got Ter2Blend to work. :smiley: But Now I am facing another problem: The terrain size. Tou see, I´ve made a script for a terrain that is 513 x 513, but Ter2Blend can only import terrains that´s 257 x 257. I thought “No problem, I don´t want objects along the whole animation anyway” so I cut the Terrain down to 257 in PSP. But when I import the Terrain to Blender, the Terrain and the camerapath get´s misaligned :frowning: . I´ve tried to align it manually, but it doesn´t work. Any tips for converting camerapath/terrain or anything at all that can align the camera and the terrain is welcome!


(blenderanim) #2

In the Landscape window, click the metres button in the lower left. It wil open an options box. Click the 257 to create a 257x257 terrain units world. That would be the simplest. If you have to have a 513x513 world, you will have to tweak the settings.

I think the limits were put into Ter2Blend to make the render times reasonable and allow for typical computers. Since most people have a lot more memory than 1 or 2 years ago, it might be possible to increase the limits. You might try sending an email to Guy at: [email protected]

blenderanim


(Detritus) #3

Well… That didn´t work out. The terrain got all distorted. But I don´t think I quite understand what you mean. Which settings was I supposed to tweak?


(blenderanim) #4

Sorry I wasn’t clear.
I think the easiest is to start with Terragen and change the setting to a 257x257 landscape. I’m pretty sure you can just load the current world that you have and click the setting. I don’t remember if it will clip to a corner or distort the world.

The 257x257 is NOT the resolution of the output image. I just realized that this may be where the confusion is. 257x257 is how many terrain units your world is. I think it equals something like 7000x7000 metres. That is more for recreating real world maps and maintaining dimensions. You probably want to render your image at 640x480 or higher.

Blender is displaying the “world” and using the created .BMP as a backbuffer image for reference. When you crop the .BMP image, you aren’t changing the underlying terrain, so it will not align correctly.

The “tweak” I referred to was to adjust the camera path. Remember that Ter2Blend also has Camera and Blend2Ter. This will give you more control over the camera path to match the Blender and Terragen scenes.

I hope this helps. Just make sure to set the 257x257 in the Landscape options NOT the output size.

blenderanim

From the Ter2Blend site:
Features of the Blend2Ter script New

This script converts your Blender camera path in a Terragen animation file (tgs file).

Why could you ask?

Let’s see…

Terragen animation scripts are usually made with Terramin or Campath. And those two programs are indeed the best for “Terragen only” animations.

With the terrain script of Ter2Blend it became possible to import a Terragen terrain file (ter file) in Blender and place objects into the scene. And it is also possible to make an animation with the camera script of Ter2Blend by importing a Terragen script file (tgs file) produced with Terramin or Campath.

But to obtain the maximum controle over your animated camera it would be logic to make your camera path in the Blender scene and then export this path as a tgs file into Terragen.

This is now possible with the Blend2Ter script.


(Detritus) #5

OK, then I understand. I guess I´ll have to do the camerapath by hand :frowning: . Anyway, thanks a lot!