Test Scene

Here is a scene from a school project I am working on that combines 3D environments (which I have never done before, can you tell?) and a 2D character. Any idea how to get rid of those lines at the edge of the image planes? I promise those don’t come from pixels that I failed to erase in the image that I used. They are always there. I used gimp to export the image sprites if that’s a clue.


I’m also thinking I should tone down the tv lighting a bit and not jump from color to color so fast. What do you think?

Any other suggestions?

I think adding a texture to the 3D materials would help. the phone looks super-imposed even if it’s not.

1 Like

Good idea. Re-rendering again with textures. I’ll re-re-render if anybody knows how to get rid of those little lines. :laughing:

It appears it’s gonna be a pain learning to uv unwrap stuff. :neutral_face:

Figures I find out the same day I post this. I imported the images using the “Import Images As Planes” add-on, which imports the images as planes that are the exact dimensions as the source image, but apparently, it glitches out and repeats the edges a bit, so I set the image texture node to clip the image instead of repeat it, it works fine. . . .
wish I had know this a lot sooner. XD

Very nice experiment to mix paper doodles with 3D.

For the edges I would use another texture so it can control the alpha. This is very similar technique on how game engines handle alpha in such materials, such as leafs, fences, and it works fine.

This can be a simple texture painted right away inside blender (no need for advanced tools), as an additional technique, you might try to mix this special texture with an noise, and get even better grainy effect. That you will have to test though if you find it good.

2 Likes

Thank you, @const !

I’m pretty satisfied with the paper texture that comes from the scanned drawings, I don’t think I need to do anything with that. I found out that since I had switched to cycles from blender render, the “clip” setting in the image texture node was not on. I changed that and the weird lines on the edges went away.

I’m also experimenting with freestyle outlines on some of the 3D objects, but not in this scene. :smiley: