Texture Bake is Always Black

Whenever I try to use the “bake textures” function all I get is a completely black UV map. I have no idea what could have caused this, since baking seems to work with any of the other types of map, like Ambient Occlusion or Shadows. Is there some setting somewhere that I might have missed?

I’m using Blender 2.49, in case that matters. Thanks in advance.

1 Like

How many objects are you using to bake?
Check two things:

  1. You have a lamp in the scene
  2. All objects have Shadeless turned off (materials panel)
  1. I have a Sun lamp in the scene, would that count?
  2. Am I right in thinking you meant this panel? http://i199.photobucket.com/albums/aa73/TBot_Alpha/Public%20Sharing%20Album/Blender_shadeless.jpg
  1. I have a Sun in the scene. Would that count?
  2. I assume you mean like this? http://i199.photobucket.com/albums/aa73/TBot_Alpha/Public%20Sharing%20Album/Blender_shadeless.jpg
  1. I tried it and it does
  2. Yep

If you still get a problem, I find that Blender is a bit picky sometimes.

  1. Tab into edit mode
  2. select all>>unwrap
  3. New Image
  4. Set up lighting and objects etc
  5. Bake

I have tried that, and it didn’t work. What’s more frustrating is that this was working fine before: I baked colour maps several times while working on this project already, and then it suddenly stopped working altogether.

I tried baking a texture map with another, seperate model, and that worked just fine. Is there something I could’ve done to my model by accident, that might cause this problem?

maybe you have set the object for not-render - the little photo-icon -
baking is part of the render-engine in blender and objects set to be not
used in the rendering cannot be baked -
Set an object not to render is usefull to speed up the test-renders to check
other objects or for objects, that should not be part of the final scene…

or you have locked some parts - this little key-lock icon … or you disabled the uv-unwrap to be used for bake (the photo-icon in the uv-map-list) etc.

try posting up your blend file so we can see

I had a similar problem but it was that it failed to bake at all. Not sure if this would relate to your case or not but…

I have never figured it out any settings that had changed. I uploaded a scene here once and nor could anyone else.

My conclusion was that there is a bug someplace that causes baking to stop working and even when it does it is rather tricky some times.

My solution then is to simply open up a fresh scene and append the object. In the new scene the object bakes fine but in the “corrupt” scene it does not. This was the case in the file I had uploaded some time ago. I could not find what was different other than a fresh scene.

This recently happened so I have started to just do all my baking in another blend as a matter of practice.

You say it is baking black though. In my case it would not bake at all. Not sure if this is related or not.

Thank you all very much for the advice, but I just got it working again on my own.

It was the “texface” setting in the Materials panel that was doing it: any material with that setting enabled showed up black in the texture bake. Whole model with that setting enabled = black UV map.

Live and learn I guess. Thanks again.

1 Like

Hello I’m having a problem my normals are fine and my uv’s are fine my texture bakes are always black I followed Introduction to Cycles Baking by Blender Guru on Youtube and downloaded two of his sample blend files when I go into material mode I always get black materials…

Missing a shader in the node editor seemed to be the problem for me. I added a Diffuse shader and the bake worked