Texture isn't showing up on hands

I’m not sure what’s going on here, except that the hands were originally part of another mesh. I want them to lose the black and pick up the colour on the texture to the left.

Any good ideas on what the issue is or how to fix it?

Thanks in advance

flip the normals?

Are they assigned to that material? I second the motion that the normals might need to be flipped as well.

Thirded. Those faces look pretty dark. Flip the normals.

Ok normals flipped, problem solved…in the render. In the viewport I now have this:

What material is it assigned to? Do you have all one material, or do you have several across the mesh?

Also, enabling GLSL turns most of her pink. Can anyone tell me what is going on there please?

There are/were two legacy materials. A nice viewport result gained from deleting these whilst GLSL is enabled, but then switching back to multitexture returns the black hands! :slight_smile:

Can you upload a file to look at? Pink usually means something is missing in texture, like an image has been moved away from where Blender expects it to be in the folder structure. It also looks like enabling GLSL solved the problem with the hands.

Sure: https://dl.dropboxusercontent.com/u/13211994/Fairy.blend

It looks fine and works here - I am observing in Texture draw mode. I would suggest though that you get a larger texture to paint onto the skin since the rest of the body shares such a small area with the hands. The hands have somewhat normal detail size, and the body and face have giant details.

ok thanks.