Texture Issue - Black areas (Cycles)

I have been having an issue ever since I started using cycles and it is really getting on my nerves now, I have been forced to remodel many models because of this annoying issue, and I have been unable to get the slightest idea as to why or how it occurs, or how to fix it.

The issue is that when I am texturing my models, I get areas that are black, this isn’t because I haven’t assigned a material for it, the material is assigned, it just doesn’t seem to be there. I can often fix it by making the face in question smooth, but that is a poor fix because it still looks out of place, just not as much as a pure black area. I know that the issue is related to the diffuse node, if I take that out it is fine but a fully glossy model isn’t going to look particularly good. It is also not related to any textures I have assigned, this one is my base shader that I have in my start-up file to save a little time but it is the same as any other mixed shader I would make. The materials are fine until I add in the texture co-ordinate node, If it is going to happen it will happen then. For a very long time I have been at a complete loss as to why or how this happens, I have tried many things but have never been able to determine how to fix it properly. I have worked out that it is most likely to occur on circle/cylindrical objects like the one shown here, and I might add that this model is nothing fancy either, as it is now it’s just a simple cylinder with some detail along it.

As mentioned before, this model is not the only one that this occurs on, the actual texture image doesn’t matter either, and it occurs with both GPU and CPU rendering. I have recently installed Blender 2.71 so it’s not an issue with my installation with Blender, this also occurred with both my old GTX 560Ti and GTX 770 and my i5 processor. I have 8GB of RAM so I don’t see memory being any issue here, especially with a model this simple. (also this particular real time render is done with GPU render) doing a little experimenting it also appears that the problem also occurs with a proper camera render, but it occurs somewhere else (a little further down the mesh but on the same ‘line’ as where problem face on this one is)

Any help on this issue would be greatly appreciated.

Regards, Nanopizza


Glitched Textures.blend (969 KB)

Doubt this is useful, but when I had problems like this it was usually an issue with the Normals, so I used the Flip Normal and Recalculate options to sort it out.

You’ve probably already tried that though. That’s the best noob input I can make!

I’m afraid that doesn’t seem to work, but thanks for the feedback anyway.

it could be many things. I would suggest uploading the model so that we can take a look at it. In the meantime check for duplicate faces.

Good idea, I attached the .blend to the original post.

This is a very strange result of the box projection, in the texture node, perhaps a bug. Try to unwrap and use UV mapping instead.

It goes away when you adjust the blend of the box mapping slightly higher. .0001 did the trick.
It shouldnt do that though…Probably some sort of bug.

That appeared to do the trick for me too, It’s almost embarrassing that it was that simple to fix lol, after all that time remodelling things I could have just typed “0.01” xD

Thanks for the help with this, I did try this on another model with the same issue and it fixed it too so I think this fix is universal, I appreciate the help with this, it means that I can make models without worrying about this ‘game-breaking’ bug :slight_smile: