texture map input problem

I have a (maybe stupid) question about the four buttons “flat/cube/tube/sphere” in the texture map input tab. No matter which one I select the texture always looks the same. What’s my mistake??? Is it a known bug (I couldn’t find it in the bug-tracker)?
Some remarks:
These buttons always worked fine until blender version 2.42a and do not work with a freshly compiled blender (a snapshot from 21.10.06). I’m on Linux here.

I would be glad about any hints - e.g., does it work with the windows-version?


anyone with an idea?

You did look at the Wiki, right? There you’ll find the informations about how these mapping types work. And yes, they do have an effect on how the texture looks on the mesh. But since they have worked for you until now, you should probably try to re-compile or something. Sounds more like a problem of you blender than a Blender problem in general (I’m quite sure some Linux users would already have noticed this?).

ok thanks
I think I understand it now (always good to read the wiki)