Texture not showing correctly in rendering

I have a dragon model from Sintel. And I redid the texture map, combining all the individual 4k x 4k body parts maps into one large 8k x 8k texture png map.

When the mesh is in object mode then the texture appears correctly. However when the object is in render mode, the texture map is all misaligned.

Seems like all the rendering is only using the upper right corner of the 8k texture.
searching for the fix.

I unpacked and deleted the old textures. And re packed the new 8k map. I cleaned out all the old materials as well. So there is only one material map left - the 8k texture map.

Here is the dragon in object mode –

Here is the dragon in working window render –

And here is the 8k texture map

Seems like the render is using only the mapped texture in the upper right quadrant of the 8K texture

Look if UV map used for previewing in the viewport is the same as one used for rendering in the Properties Editor > Object data.

Yes, they are the same …

How could one guess then?
Reason is apparently on the object or object material settings level.
See if object has any modifiers and disable them if they are.
See if there are any nodes connected to material output except for the image texture, shader and output. Disconnect everything if any. Then connect only image texture to shader. If there are more than 1 UV map plug UV Map node with its name into the Vector input of the texture to be sure.
Texture resolution makes no difference. 256x256 texture would be visible in the same way as 8k if everything else is correct.

Good points. I’ve done that, disabling each modifier to no effect.

But… what does clear it up is when I clear out everything and export the mesh as a WAV Obj.

Then the mesh appears correct in both texture mode and working window render mode.

I’m gonna reimport the rigged mesh again and start fresh