Texture not updating in cycles render, works fine otherwise

I’ve been editing my UVs and noticed that the changes won’t apply when I render the scene. I tried restarting Blender to no avail.

As you can see, in the first image the textures are correctly updated on the building in the middle, and in the next the texture reverts to when I first started editing my UVs. Any idea what would cause this bug?

Is it possible you have used the UVmap node in the shader node editor or have more than one with the wrong one selected to render? In the image UVmap is set to render while UVmap.001 is not.

1 Like

Hmm I don’t believe so, here’s a screenshot

Yeah, I don’t know,
I’m at a loss.

EDIT: cycles right?

1 Like

Correct, Cycles

You’re using some color output as displacement input. Use a displacement node.

That’s intentional. In any case, I tried what you suggested and no change

Intentionally ruining normals when a glossy (or anything, really) is used, doesn’t make sense.
It’s unrelated to the UV problem though. Share the scene, one textured building is enough.

I’m not allowed to upload attachments, but here’s a url: https://mega.nz/folder/HUswVQBB#ZUqMxpA8weL602Pgoau8-w

Thanks for taking the time. The buildings are all one object so I kept it as is, but understand if it’s too cluttered and annoying to diagnose as is

Two of the buildings have duplicate geometry in them, causing z fighting.

Oi vey, a bit embarrassing. I appreciate your help! That was the issue