Texture on Rubber Duck

(Henske) #1

Hi,

I’ve finished a model of a rubber duck today (1st pic) and wanted to give it some color.
I have tried to do paint the model partially (eyes & beak only) by selecting faces in UV face select, unwrapping them and paint directly in the 3D mirror (or UV image editor).
This worked reasonably well but after saving the blend file AND saving the texture images, the texture was no longer in the rendered picture after re-opening (pic 2)
Instead of the texture i’ve made there are only black faces.
However, in texture mode (3D view) i can see the texture i’ve made but somehow it does not show in the rendered picture.

Who can tell me what I’m doing wrong, or maybe knows another way to paint the duck like the original (3rd pic)

Thanks in advance.

Henske

Attachments




0 Likes

(RamboBaby) #2

Try recalculating normals outside. Editmode>Select all verticese>CTRL+N>Recalculate normals outside.

0 Likes

(Alltaken) #3

What you need to do is map the texture as a texture channel in the materials setting (if you haven’t done this)

When UV unwrapping the image you see in the 3D view is not necessarily the one that will render based on your material settings.

As a quick way to solve the problem (with basic functionality) press the TexFace button in the Material Buttons Window. this will apply the current UV map to the object as if applied using the COL texture settings.

I hope this solves the problem that you are facing.

0 Likes

(Henske) #4

Yey, did it, and it worked!!!

I assigned the images as texture to the material it turned out to fix this problem!!
Not right away tough, I had to fiddle with several settings to get it work and I’m not even sure anymore what I did to make it work!!
Does anyone know a good tutorial on (local) UV mapping to help me understand what i’m doing??

One other thing: in object mode (textured draw type) the beak has a purple highlight which I cannot remove. Any idea why this happens and how I can remove it?

Thanks for your help so far!

Henske

Attachments



0 Likes

(RamboBaby) #5

It’s purple because you removed the TexFace image.

0 Likes