Texture Paint mode says missing textures although that there are no missing textures

Hello,
I am trying to make to eyes out of spheres. I gave each eye a single material. After that I linked both materials to one Image Texture. Now if I want to draw on the texture in the Texture Paint mode, it says that there are missing textures and the not selected eye is pink. I already searched the internet for answers but did not find anything.

Edit: I created a new project. Added two spheres, gave them the same material, used nodes to connect the material to a image texture that was created by clicking the new button and then in Texture Paint mode it worked perfectly fine. I tried the exact same process several times in my other project and the Texture Paint mode says “Missing Textures, detected!”.

  1. Edit: I made a few pictures to show my project setup. The picture is high resolution so you should be able to zoom in and read everything. If you can not read it and Blenderartists scaled it down somehow, please say so.

I am looking forward for coming questions and I appreciate any help.

Best regards,
Timo

Can you attach a few images?

Why do you create two materials for the eyes when only one is needed?
You can try not to create your own image. Just add sphere-> Create material and go into texture paint mode. Then right hand toolbar click on the plus to create a color image texture and it will setup automatically for the material.

I tried that right now and it didn’t work.

But still, thanks for the help. If you have an other solution, let me know :smiley:.

I assume that you mean that I give both materials a different image. I did that but nothing changed.

Anyway thanks for your help. If there is anything, let me know.

I will check again when I am on my pc… the easiest thing would be if you could upload the blend file when it is possible

Alrighty, here is the google drive link to the file:
https://drive.google.com/file/d/18mHNObd0Y9PAOK86xgySag_0ippmq93E/view?usp=sharing
Thanks for your time.

Didnt expect such a big file size from the screenshot… =D Quick note the .blend1 file is just a backup when you save the current version will be the .blend1 and a new version will be saved. This can be deleted or keep it but there is no need to send it with the project.

For the solution. In texture paint mode in the upper bar is a texture slot option. Yours is set to single image without an image. Change it to material and it will detect your created image.

Error is gone but i need to check more i still cant paint on it…

EDIT: Got it you in the brush setting under texture you selected your image with will do nothing… Its for brush textures and not where you want to paint…

Nah I meant screenshots. It’s fine though, @schamph solved your problem :+1:

1 Like

Yup, that was the solution. Never thought that it would be something like that.

I appreciate your help and your time. Thank you.

1 Like

Glad it helped but i would have not caught that from the screenshots so the file was helpful.