Texture Paint Opacity Default Value

Hi there!

I know that 2.8 is suposed to be frozen. But is the Texture paint opacity default value really going to be 1 (100%)? I just think it is a bit strange because 2.79 was not like that.

There was no texture overlay in 2.79.
So, result was shadowed by default without simple setting to enable a flat shaded mesh.

Should texture overlay provide a Studio Light look or a shadow ? maybe. I don’t know if there is a technical issue or if it was not done by lack of time.
Should default be without texture overlay ? It was complicated to set up UI to use GLSL in 2.79. Display was not as great as what EEVEE brings, now. So, in 2.79, default is also to see only effect of one texture when painting.
Problem may be that old hardware may have difficulties to support EEVEE’s Rendered display and in that case Solid view with Texture Overlay is more suitable.

Anyways, no matter what default is chosen for 2.80. Result cannot be similar to 2.79 look.

The default texture painting opacity is 70%. Indeed that’s very arbitrary. It obviously should be 1.0 / 100%.

Hi, William and Zeauro.

If the opacity is 100% (1.0) we get this flat look. But if the opacity is 0% and the texture color option is turned on in the viewport shading options we get a more usual feel for painting. Is this flat look as a default intentional?

You are right.We can do that, now.
In early version of 2.8, there was no Texture color.

Texture opacity slider was there to overlay a lookdev view showing result of all textures of material.

Jeroen made Textured models supported by Matcaps display, this afternoon.
So, it would be logical that Texture opacity slider simply respects active Lighting mode of Solid display.


@Gustavo_Rosa It works as you suggested, now.



That’s right, thanks devs!
I have noticed that Opacity slider is acting like it = 0 which is what had been suggested, but in reality what happens is that value is set to 1, although opacity slider seems not to be working.

Wow! Thank you, Zeauro! :slight_smile: