Texture Paint

I don’t see a way to have an image saved with the alpha Chanel from the UV editor. After I paint the texture, I save the image and then the UV Grid is there, in my final image. I thought the grid was just a transparent guide …I guess I might be doing something wrong here. Something like this is what I get when rendering the image.

Any tip?:o


Strange as it is, you have to turn on RGBA in the Render panels to save an image with alpha, even from the image editor.

Well, certainly it is checked ( RGBA) in the render’s panel. I have gone around this for some time by now. Tried PNG, TGA. New image with Alpha enabled ( Checked ), disabled. I tried clicking the icons: Paint with RGB only. Paint with RGB and Alpha ( which should do it, but it doesn’t )…I am giving up with this:eek:

When you open a new image in the editor, make sure UV Test Grid is unchecked. It will tile the background and is not a zero alpha transparent guide. Why the grease pencil can have layers but not the image painter is beyond me.

Yeah that’s correct. If I do not use the UV_grid I can setup my color with Alpha 0 when the image is created. In that way I can save the Alpha channel. Thanks for the Tip!

However why then do we have UV_Grid? Noone wants it on your model. I guess the UV editor is still under development. If you move the color slider when “creating New Image” then an image is created on every step of the slider, creating: Untitled, Untiled001, Untitle002,…etc easily it gets to hundreds of images. It seems it has some autosave in some where.

Well at least i can do what I need to do, just not using the UV_grid.

Thanks man!:spin::spin:

The grid is very useful for checking whether your image will contain any stretching or other distortion when applied to the model.

Uhhh…got you!