Texture v. dark on one object, no reason?


I’ve got a strange problem … the textures in textured mode are showing up extremely dark on this object. I don’t remember doing anything strange to the material or object settings. Texture bake produces proper results, I just can’t really see them in the 3d view.

I’m using bebraw’s build but I get the same problem in the offical 245.

Here’s the object and its uvmap:


And there’s the object from the bottom, which is the brightest part of it (i can’t see the tex at all on the top); just to be sure I did a two-second crapular unwrap on my sizing guide room thing, and applied the same texture to it, and it’s displaying as expected:


I tried throwing a few search strings into the forums, but didn’t come up with anything useful.



I know I am so new that helping you is stupid, because you have been there and done it all already…

but, I read on the GE forum that the edit mode textures have been added to the new blender.

And in the first picture you are in edit mode? Perhaps that has something to do with it.

Also, check to make sure you didnt hit the vertex paint by accident, it will always load a dark image for the verts. I did that once and it made me crazy, because the object was so dark…but then I found it.

Eh, I haven’t really been all that far with this, I still don’t know how to do a lot with UV.

But for that … I’m in edit mode in the first pic, but the top is about the same darkness in object mode. I’m in object in the second pic, but it’s about the same in edit.

And I don’t THINK that the second thing is a problem becausde I went and tried to re-set the image to the UVs a few times; plus I can see the image, it’s just darko.

Last time I had a bizarre shading problem it was because an object’s DimZ was somehow zero (actually happened to the room placeholder around this, but I already checked that and that made it dark in solid mode.

Need to go poke around some more.

And I don’t THINK that the second thing is a problem becausde I went and tried to re-set the image to the UVs a few times; plus I can see the image, it’s just darko.

Even though you reset the uvs, you could still have a vertex paint thing. Oh its called a vertex color.

And when you first use it, its set to dark, so you can still see the image, but its dark.

I have one on this model, and even though I keep deleting it, if I add a new one, it has white blotches all over it, from the first time I used it.

I deleted it then, because it was too ugly to use. But it keeps coming back like a ghost. I asked here, they said it wasnt a bug, just a glitch.

so as far as this models goes, no vertex painting on it… And I have like saved it to different files, imported it etc… still its stuck to the model.

I think I may have just ran into the same thing as you. All of a sudden all my verts on my models’ hands are dark and the uvs are pointing out.

I noticed a couple stray verts and deleted them on one hand and BOTH hands went to the normal color…

So look for a stray vert or two…

Bloody heck, it was the vcolpaint thing. I didn’t realize that just sneezing at vertex paint mode will create a black vertex paint map or whatever it’s called. Thanks :).

I posted last night, but its not here today…

I said you are Welcome, just glad it is fixed so you can move on. I hate being stuck…