Textures disapearing in render

Hi everyone! Got a strange accident when my material perfectly displays in viewport Cycles, but engraving and color totaly dissapears in final render? What is the possible reason? The engraving area is just base color + bump


Maybe you just did hide some material from render?

How to check it?

Make sure all photo icons here are enabled


Also make sure that you being in viewport shading mode. That shows you the actual final render in real time view

Try to experiment with your nodes. Disable one by one and do a test render to check if the problem still exists. Is that engraved text are an image texture? If so, try to connect image texture node only and do a render. If the text will appear - the problem may be with your nodes.

Advices were not very helpful, but thanks, fixed it by redrawing the texture. Some bug with Texture Paint mode

Always save images manually after you finish drawing, even smallest details. Blender undos all your work if you dont

Don’t underestimate the questions which could be solved by this simple hints…
…and it wasn’t noticable in your partial screenshots… :person_shrugging: