Textures in Blender Game Engine

I’m using 2.68a, and when I play my game with textures, it works fine, but when I add UV mapping with a texture painted image and added it to my object, IT DIDN’T SHOW UP!!! what’s up with that?

What game mode are you using (GLSL, Multi-texture, or Single-texture mode)? Also, did you save the texture painted image at all yet?

Do you intend to say that the object didn’t show up or that the texture did not show up? If the object did not show up, make sure that you have not accidentally clicked invisible or changed any alpha values, and recalculate the normals in edit mode.

@SolarLune: I have no clue what game mode I am. it’s the default one, which ever that is. I know what GLSL is in BIR, but not in BGE…sorry about that :confused: where is it located? I did texture paint it in blender and I did save it.

@MrPutuLips: The object itself didn’t show up because my counter property (it counts if object is added to the game scene) worked. I did not click invisible and I didn’t change the alpha vals either. I don’t think normal have anything to do with this because I have a smooth on my object and it doesn’t show any black/dark areas at all

I think there was a bug with multitexture mode and modifiers. I can’t remember if it was fixed or not, but you may want to try removing any modifiers. If that causes your object to show up again, try a more recent build of Blender.

Found the bug I was thinking about: https://projects.blender.org/tracker/index.php?func=detail&aid=29575&group_id=9&atid=306
Looks like it was fixed in a revision that was after 2.68a was released.

Ok, thanks a bunch. reinstalled Blender. Hopefully that will solve the problem

nope :confused: the strange thing is, when I opened a new blender and texture painted a cube and made it move around, it was perfectly fine…but when I tried to add a texture to my FPS game, it still didn’t show the object…