Textures not showing up

im following the splattering and library linking tutorial. http://vimeo.com/15679785

Im at the part where he applies the grass texture and i follow him exactly, when he presses alt+Z and the texture shows up on his 3d view. my 3d view “textures” the scene but it stays gray. the grass doesnt show up at all.

now heres the kicker: when i render the image, the grass shows up fine. So what makes textures show up in the render but not the 3d window? is it button that i missed somewhere, a hotkey that i hit by mistake, or a bug in the program? in any case, how do i fix it?

EDIT: File attached so anyone can view my settings
-Missing texture file. Fixed.


Lake Path.blend (593 KB)

You haven’t included the texture in your blend file. But just guessing:
You need to activate the texture (tick box next to the texture)
You need to be in GLSL display mode (in the properties (N) / display settings)
Attached blend with a substitute texture


Lake Path.blend (300 KB)

Just set GLSL mode. it was on multitexture, it still didnt fix the problem though.

Grass texture is still not there, but I can tell you that you have the grass’s texture channel set to “generated”. Switch it to “UV”.

Fixed. thank you guys very much!