Textures within the Game Engine (2.49)

Hi, back again with another question…

I’ve scoured this site and many others with help for this, and it seems to be a common issue but no matter what I try, it still isn’t working for me.

I cannot seem to get my textured objects to show up when I enter the BGE and I’m not sure what I’m doing wrong.

I’ve opened my image and can see it fine in Texture Paint mode, but then it disappears when I run the game.

Please help!

image textures should be “assigned” to objects with the UV Editor!

Hi Oto, thanks for your reply.

I did use the UV image editor - how do I assign the texture?

*edit mode <tab>
*select the faces you want a texture on (<a>)
*unwrap <u>
*in UVeditor choose the texture to assign or load a new one from file

Hi Monster,

That is exactly what I tried and it didn’t work in the game engine. Do you have any other advice for possible solutions?

Thank you

It seems like you have problem in either GLSL or multitexture mode. Try to switch it.

Thank you for all your help, it turns out I was doing something stupid…

Any chance you could help with a scripting problem I’ve been having? I posted it last night in the Python section of the forums.

Many many thanks again

If it is BGE related you should open a thread here.

How do I loop a video texture, so that it just keeps playing on and on?

hi jem.714 or anyone else, i have been having the same problem as you but i haven’t used any scripting it’s a real pain anyone have ideas??? i’m using 2.5