Texturing Complex objects

This is a kind of nooby question -

I have a complex object that I want to texture with an image. When I try though, it comes out unicolored. What can I do to fix it? :frowning:

What kind of object it it and what is the image map you are trying to apply?

Can we see some shots or the blend file to take a look at what you are trying acheive?


It’s a tree trunk.

Here’s a shot of the tree + the texture I want to use:

(You might have to copy/paste the url: ‘http://photos1.blogger.com/img/146/1746/1024/treetex.jpg’ into a browser)
*edit: Right Click>Show Picture seems to work too. :wink:

When I render it, the tree comes out pretty much unicolored. Hope that’s enough to see. If you need, I can also post the image (688x1297 JPEG image). It came out okay on a box.

Thanks in advance :smiley:

help :o ty :smiley:

you’re probably going to kick yourself when i tell you this…

in the [map to] tabbed window, you only have -[displacement] turned on

turn on [col] and it should work…

but your question is still a bit vague,

so could you possibly post an image of your render…?

Hope this helps…


Sorry-didn’t realize the importance of material settings. :expressionless: Here’s a pic of the color, bump, and displacement maps with a couple renders (Subsurf, Subsurf+Set Smooth):

Copy/paste this into a brower (maybe Right Click>Show Picture - doesn’t always work):

Or it’s the “texture problems” picture here: http://mwindu89.blogspot.com/

You maybe just need to scale the textures down by setting the size in the map to section. I think actually increasing the size scales it down. Make size x,y 10. I have to do that all the time for wood textures.

And I wouldn’t recommend using both a bump and displacement - displacement maps are rubbish in Blender because they don’t have true displacement yet. This means you have to turn the resolution up reeeeally high and when you think you’ve gone as far as you can, think again.

You also won’t really don’t need displacements for the tree. Bumps will do fine.

I tried scaling the texture to several different settings. It still doesn’t show up - it’s still unicolored. :frowning: Do you resize the texture for trees? :slight_smile:

Yes you resize the tree textures. Make sure your normals are all pointing outwards and try switching on/off the double sided button.

If you’re still stuck, can you post a .blend file?

I don’t have a site or anything where I can upload the .blend. Is it okay if I email it? :slight_smile: