The big Blender Sculpt Mode thread (Part 1)

Oh, so it’s a division by zero ?

That one, or a very big term given by interpolation, possibly. Not sure, I didn’t check the code.

Anyone used the switch objects in sculpt mode lately? Isn’t it supposed to be hover with the mouse and press D?

From Edit > Preferences > Experimental, you must enable the option “Switch Object Operator”


Ah, thanks! It being an alpha version and all, might as well switch those on by default. :smiley:

1 Like

That is weird to see that treated as experimental.
Ability was already there in 2.7x for right clickers.

Yeah, but a lot has changed since then. Mode switching is a weird beast, given how Blender’s undo system works.

IIRC they made it experimental because the D key still sort of conflicts with annotate. Not sure why it takes so long to make a decision about it, though.

If it were up to me I would remove the annotate hotkey. Annotate isn’t used frequently enough to warrant being on a homerow hotkey, and it works quite a bit better as an active tool anyway. Alas, I’m sure if they remove it someone will complain.


Not related to sculpting, but there is a time frame for the already mentioned texturing improvements?

There is not. :man_shrugging:

Newbie question. If I have 2 intersecting objects, how I can mask the intersection or make a different face set for it without extra steps.

Blender Sculpt mode was not thought to handle several objects.
And generally speaking, multi-object editing is relatively new in other modes.

You have to make extra steps.

You can pass 2 objects in edit mode, select visible elements, invert selection, go back in Sculpt mode and create a Face Set from Edit mode selection.
Or you have to hide faces that are not intersecting in Sculpt Mode and create a mask or a face set from visible faces.


I really can’t rely on edit mode when sculpting model is like 10m polys…



I use it all the time. I’d prefer to change one hotkey to get annotate functionality back in Sculpt Mode (or… live without it in sculpt mode I guess?), rather than adding the annotate hotkey for every mode again!

That’s one thing I dislike about the Sculpt Mode developments (next to lots of things I like): the sudden changes of long-time keyboard shortcuts. For example, ‘S’ was always the very important Smooth brush, and it was suddenly degraded to the Shift + S key combination. Shift + R was Repeat Last (and still is everywhere else in Blender), which I use a whole lot, for example to repeat mask smoothing. Right now you need to go into the Preferences and search for a key that’s free in order to have Repeat Last back in Sculpt Mode.


Yeah, Scale on S just trips me up in sculpt mode. I know it’s standard across Blender, but Scale is just sort of useful sometimes in the initial stages, whereas Smooth is probably the most important brush throughout.

But I have to say, I’ve never, ever used Annotate while in sculpt mode. In Object mode, yes. Sculpt mode, never. And now in Object mode I increasingly just go Grease Pencil instead of Annotate.

1 Like

I understand that a user may draw a quick sketch, a reference of model he wants to sculpt.
So, I am fine with presence of Annotate tool in Sculpt mode, when he is changing his mind about some proportions, ideas.

But if every developer is fine with that, too. Why demolishing its use by forcing hiding of 3D Cursor ?
That simply does not make sense.
3D Cursor placement is requested by Annotate tool.
There are 3 possible stroke placement methods. 3D Cursor, View and Surface.
View and Surface are not the ones, used by somebody placing fixed templates in 3D space !

3D Cursor may be hidden by user if he is annoyed by it.
It can be disabled in Sculpting Workspace without messing up other workspaces.

So, why breaking annotate tool use (that requires 3D Cursor placement) by adding an unnecessary exception to Sculpt mode display?

I recently discovered (and sorry if this was mentioned in the thread) that in Sculpt mode you can use only the “R” key for all the 3 transformations.

Meaning: if you press “R” you initiate a rotation. But if you then press S or G (before cancelling) you can scale or move the object (at the bottom appears this info). So you can free the “S” key for other brushes/tools.

Also: while in Sculpt Mode if you left click (left click selection) and drag in an empty space of this panel (where the cursor is in image below) you can also move the current object in the viewport (I think it’s a bug but I didn’t report it because… is handy).


It’s already collecting dust in the tracker… hehehe…

Reported a long time ago… :no_mouth:

1 Like

Maybe you should try patching it.

1 Like