The latest additions to cycles has made it nearly real time (Theory Build)


(LordOdin) #1

Thanks to lukas stockner and a few of the main cycles devs cycles has become 10x faster or 10x cleaner… We can denoise, We can blend between noise, We can even remove the randomness (noise) from the sampling to get clean renders from the first sample, We can switch to AO after a certain number of bounces. We can limit texture size to fit our previews in to vram… We can hide geometry far away, We can hide geometry behind the camera, We dont sample lights that we cant see, We dont sample lights that are too weak to contribute to the scene, We do a lot of things apparently… Who is “we” IDK what im talking about its 3 am… Enjoy this video and maybe download the build



#2

Some of the things that you told

  • Hide far geometry
  • Hide occluded geometry
  • Don’t sample weak lights
  • DOn’t sample occluded lights

are automatic or we must configure in some way?


(LordOdin) #3

Sorry about the messy post haha


(tuqueque) #4

@LordOdin… Is the class room scene available for testing? I’d like to use it to test my SSGI node. Thanks in advance.


(LordOdin) #5

Yup its even on the blender.org website


(tuqueque) #6

Oh, I totally forgot about those. Thank you very much!


(Avenger) #7

Does the occlusion account for lamps that are outside of view but still contribute to the scene, e.g. shadows?


(LordOdin) #8

It is only for lamps that do not contribute to the scene I believe. So no it wont just randomly make lights turn on and off


(Doisy Didier) #9

Opencl not working here! Snif! Did anyone got the same problem “Failed loading render kernel”


(LordOdin) #10

Yup Sadly. Lukas knows about the problem it will probably be fixed soon


(SamCameron) #11

In the video you are changing several times the AO distance but the AO it self is off, what is the reason to change that and having the feature off?


#12

Thanks LordOdin!


(J_the_Ninja) #13

The interface is a little deceptive. The checkbox is for the “world AO”, which is an ambient lamp with built-in occlusion. The distance still affects the AO pass and the AO-after-diffuse bounces thing, even with the checkbox disabled


(Ace Dragon) #14

I don’t think it quite works like that. The threshold kicks into gear when a shadow ray is below a certain level of energy (and below that threshold it has a chance of being terminated). The samples that don’t get terminated then get a higher weighting so the render basically looks the same but with lower render time.

With an aggressive approach, this can almost replace the need to mess with the min bounces parameter (because that option has a bad habit of introducing major bias if set low enough in certain scenes).


(SamCameron) #15

Thanks for the clarification, weird indeed, they should fix that, it’s confusing.


(LordOdin) #16

Because I have it set to use AO after a certain number of bounces… 1 bounce in this case.



(Sackadoo) #17

Is this just for the viewport or do renders get a corresponding speed up as well?


(Ace Dragon) #18

Everything mentioned applies to F12 rendering as well (I don’t any logic in why the devs. would choose to only speed up viewport rendering).


(English is not my native language) #19

Nice!
I do not know if it is clear in your video, I mention just in case for others that you are using “Scrambling distance = 0” in the experimental build (Render tab > Sampling).

Regarding fast rendered view on viewport, for scenes with heavy Volumetrics it would be nice to have on “Simplify” options a discriminated option for Geometry > Step Size on Viewport.


(Sackadoo) #20

Stranger things have happened. Perhaps I’m cynical—working for the government can do that to a person—but the demo didn’t show (or even hint at) F12 renders, so I’m taking nothing for granted.

Thanks for your reply.

EDIT:
Nope, I’m not getting any speed up. In fact, I just tried it and I’m actually getting slower render times. For my test scene, I got 1:11.43 with the official release, 1:14.68 for this experimental build.

I turned on camera/distance culling for all objects (frustrating since it can’t be done on multiple objects all at the same time) and turned those on in the Scene tab as well.

Is there a User Preferences setting I need to turn on as well? Or is this a belated April Fool’s joke?