totally green


Okay, so I’ve used Lightwave, Cinema 4D, played around with Maya, and dig Poser and Bryce. But this Blender thing just kept calling to me. I downloaded the 2.36 version; I’m on a Mac, the old Yikes machine, etc.

I can tell that there is a lot of power under the hood, so I wanna learn this thing… fast forward…

I keep getting this message when I try to import a LW object:

ERROR: Python script error:check console

I started clicking around and found the Script window? After I click the various buttons, I get this message;

Missing standard Python module

What do I do? is there a manual that can guide me though this process? I’m looking at the various posts on this thread as well.

What I have done, was download MacPython. I installed it, but that didn’t do anything.

Again, I’m already hooked, please help :smiley:

ERROR: Python script error:check console

For the love of God, Montressor! Whatever you do, do NOT look at the console. The information revealed there can be too horrible for the human mind to bear.

My psychotic powers tell me you either have the wrong version of python installed or installed it somewhere where blender cannot find it.

You might want to poke around on or and read some documentation.

? what is that all about? the console just gives an error output for python and is the way you find out about what the problem is and how to solve it. What is so horrible :-?

Oh and why did you download 2.36? 2.40 is the current version

Thanks, stive. I’ll go and have a look see.

Hello, Jedi Dawn.

I’m still using os 10.2.8. Blender 2.40 wont fire up under said op system :wink:

I didn’t download 2.37, cuz I noticed that the play back app didn’t look the same as the one in 2.36. I suppose I should at least get 2.37a… heh.

B4 I jump to another forum, might you have any suggestions on how to get my scripts configured?


Thanks for the suggestion!

Well, did as instructed. Still no python :frowning: situations like this usually mean I have not completed a step or did something wrong; I’m used to that, and usaully just keep plowing ahead. But I’m frustrated this time around.

Okay. I’m still using Mac os 10.2.8.
I downloaded Blender 2.37a and python 2.33
and the fink program.

After using the fink program, the only thing that changed was that I was able to import a wave obj. I was happy about that. No other scripts worked, so I may have always been able to import wave objects. I dunno.

How/where do I access the area in Blender where I can manually type in the path? When I open the script window under the “I” symbol, after typing python and rt clicking and choosing execute script, I get the same error mentioned ealier.

I even tried changing my user paths under the “I” button. No luck there either.

There is something simple that I am missing… just can’t figure it out. :expressionless:

Reading the python 101 thread, it appears folks are able to access and type commands in blend. Where is that, and is it possible to the commands to work if Blender can’t find scripts?

Where are all of my fellow mac users?

I long, long rant… won’t trouble you folks again.

P.S Even tho I can’t get it to work for me, I stand by my conviction that this is an awesome program!!!

You can type in text in the “text window” and when you hit alt + p that text is run as python code.

Lemme think… I’m not a mac user… do you have 2 windows when running blender??? The console window is then the “dos type thing” I’m afraid that that window might not be available in mac… not sure but I think I may remember something like that.